USACO 2.2 Subset Sums

Subset Sums
JRM

For many sets of consecutive integers from 1 through N (1 <= N <= 39), one can partition the set into two sets whose sums are identical.

For example, if N=3, one can partition the set {1, 2, 3} in one way so that the sums of both subsets are identical:

  • {3} and {1,2}

This counts as a single partitioning (i.e., reversing the order counts as the same partitioning and thus does not increase the count of partitions).

If N=7, there are four ways to partition the set {1, 2, 3, ... 7} so that each partition has the same sum:

  • {1,6,7} and {2,3,4,5}
  • {2,5,7} and {1,3,4,6}
  • {3,4,7} and {1,2,5,6}
  • {1,2,4,7} and {3,5,6}

Given N, your program should print the number of ways a set containing the integers from 1 through N can be partitioned into two sets whose sums are identical. Print 0 if there are no such ways.

Your program must calculate the answer, not look it up from a table.

PROGRAM NAME: subset

INPUT FORMAT

The input file contains a single line with a single integer representing N, as above.

SAMPLE INPUT (file subset.in)

7

OUTPUT FORMAT

The output file contains a single line with a single integer that tells how many same-sum partitions can be made from the set {1, 2, ..., N}. The output file should contain 0 if there are no ways to make a same-sum partition.

SAMPLE OUTPUT (file subset.out)

4


太天真了,前幾天dfs做多了,以爲又是一個二值搜索,簡單的寫了一個dfs到第四個test就開始超時了。。。哦,果然這種集合裏挑幾個數的問題應該歸爲揹包問題。設b[i][j] 是前i個數和爲j的種數。轉移方程附圖。


代碼如下:

/*
ID: gjj50201
LANG: C++
TASK: subset
*/

#include <stdio.h>
#include <iostream>
#include <stdlib.h>
#include <algorithm>
using namespace std;
int n,sum;
int b[40][850] = {0};

int main(){
	freopen("subset.in","r",stdin);
	freopen("subset.out","w",stdout);
	cin>>n;

	if((1+n)*n/2 % 2 == 1){
		cout<<"0"<<endl;
		return 0;
	}

	b[1][1] = 1;
	for(int i=2;i<=n;i++){
		sum = (1+i)*i/2;
		for(int j=1;j<=sum;j++){
			if(j>=i)
				b[i][j] = b[i-1][j-i] + b[i-1][j];
			else
				b[i][j] = b[i-1][j];		
		}
	}
	cout<<b[n][(1+n)*n/4]<<endl;
	return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章