POJ-----2115---C Looooops擴展歐幾里得

C Looooops
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 24687   Accepted: 6939

Description

A Compiler Mystery: We are given a C-language style for loop of type
for (variable = A; variable != B; variable += C)

  statement;

I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2k) modulo 2k.

Input

The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C < 2k) are the parameters of the loop.

The input is finished by a line containing four zeros.

Output

The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate.

Sample Input

3 3 2 16
3 7 2 16
7 3 2 16
3 4 2 16
0 0 0 0

Sample Output

0
2
32766
FOREVER
給定一個循環for(int i = A; i != B; i += C) (i <= 2^k),問經多少次循環,次循環可以退出,i大於2^k時,即溢出就變爲0,重新循環

因此題目爲求C*x 與 B-A+n*2^k同模於 2^k,即C*x 與 B-A同模於 2^k

轉化爲C*x+y*2^k=B-A,求最小整數解,擴展歐幾里得即可,注意判斷B-A是否是gcd(C, 2^k)的倍數

#include<cstdio>
#include<iostream>
#include<cmath>
#include<cstring>
#include<string>
#include<algorithm>
#include<map>
#include<set> 
#include<queue>
#include<vector>
#include<functional>
#define PI acos(-1.0)
#define INF 0x3f3f3f3f
#define CL(a, b) memset(a, b, sizeof(a))
using namespace std;
typedef long long LL;
const int maxn = 1e5+10;
const int MOD = 1e9+7; 
int n[20], m[20];
void ex_gcd(LL a, LL b, LL& d, LL& x, LL& y){
	if(!b){
		d = a;
		x = 1;
		y = 0;
	}
	else{
		ex_gcd(b, a%b, d, y, x);
		y -= x*(a/b);
	}
}
int main(){
	LL a, b, c, d, A, B, C, k, x, y;
	int kcase = 1;
	while(scanf("%lld%lld%lld%lld", &A, &B, &C, &k) == 4 && A || B || C || k){
		a = C;
		b = (LL)1 << k;
		c = B-A; 
		ex_gcd(a, b, d, x, y);
		if(c%d) printf("FOREVER\n");
		else{
			c /= d;
			x *= c;
			b /= d;
			x = (x%b+b)%b;
			printf("%lld\n", x);
		}
	}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章