HDOJ-----2669---Romantic擴展歐幾里得

Romantic

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5444    Accepted Submission(s): 2295


Problem Description
The Sky is Sprite.
The Birds is Fly in the Sky.
The Wind is Wonderful.
Blew Throw the Trees
Trees are Shaking, Leaves are Falling.
Lovers Walk passing, and so are You.
................................Write in English class by yifenfei

Girls are clever and bright. In HDU every girl like math. Every girl like to solve math problem!
Now tell you two nonnegative integer a and b. Find the nonnegative integer X and integer Y to satisfy X*a + Y*b = 1. If no such answer print "sorry" instead.
 

Input
The input contains multiple test cases.
Each case two nonnegative integer a,b (0<a, b<=2^31)
 

Output
output nonnegative integer X and integer Y, if there are more answers than the X smaller one will be choosed. If no answer put "sorry" instead.
 

Sample Input
77 51 10 44 34 79
 

Sample Output
2 -3 sorry 7 -3
X*a + Y*b = 1,給出a, b,問有沒有x大於0的整數解,由擴展歐幾里得,知gcd(a, b) = 1有整數解,注意解得的x可能小於0,要加到大於0爲止

#include<cstdio>
#include<iostream>
#include<cmath>
#include<cstring>
#include<string>
#include<algorithm>
#include<map>
#include<set> 
#include<queue>
#include<vector>
#include<functional>
#define PI acos(-1.0)
#define INF 0x3f3f3f3f
#define CL(a, b) memset(a, b, sizeof(a))
using namespace std;
typedef long long LL;
const int maxn = 1e5+10;
const int MOD = 1e9+7; 
int n[20], m[20];
void ex_gcd(LL a, LL b, LL& d, LL& x, LL& y){
	if(!b){
		d = a;
		x = 1;
		y = 0;
	}
	else{
		ex_gcd(b, a%b, d, y, x);
		y -= x*(a/b);
	}
}
int main(){
	LL t, n, a, b, c, d, A, B, C, k, x, y;
	int kcase = 1;
	while(scanf("%lld%lld", &a, &b) == 2){
		ex_gcd(a, b, d, x, y);
		while(x < 0){
			x += b;
			y -= a;
		}
		if(d == 1) printf("%lld %lld\n", x, y);
		else printf("sorry\n");
	}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章