[POJ2142]The Balance 擴展歐幾里得

Description

Ms. Iyo Kiffa-Australis has a balance and only two kinds of weights to measure a dose of medicine. For example, to measure 200mg of aspirin using 300mg weights and 700mg weights, she can put one 700mg weight on the side of the medicine and three 300mg weights on the opposite side (Figure 1). Although she could put four 300mg weights on the medicine side and two 700mg weights on the other (Figure 2), she would not choose this solution because it is less convenient to use more weights. 
You are asked to help her by calculating how many weights are required. 

Input

The input is a sequence of datasets. A dataset is a line containing three positive integers a, b, and d separated by a space. The following relations hold: a != b, a <= 10000, b <= 10000, and d <= 50000. You may assume that it is possible to measure d mg using a combination of a mg and b mg weights. In other words, you need not consider "no solution" cases. 
The end of the input is indicated by a line containing three zeros separated by a space. It is not a dataset.

Output

The output should be composed of lines, each corresponding to an input dataset (a, b, d). An output line should contain two nonnegative integers x and y separated by a space. They should satisfy the following three conditions. 
  • You can measure dmg using x many amg weights and y many bmg weights. 
  • The total number of weights (x + y) is the smallest among those pairs of nonnegative integers satisfying the previous condition. 
  • The total mass of weights (ax + by) is the smallest among those pairs of nonnegative integers satisfying the previous two conditions.

No extra characters (e.g. extra spaces) should appear in the output.

Sample Input

700 300 200
500 200 300
500 200 500
275 110 330
275 110 385
648 375 4002
3 1 10000
0 0 0

Sample Output

1 3
1 1
1 0
0 3
1 1
49 74
3333 1

Source

Japan 2004


題解:

    這道題與模板題唯一的區別就是,他要求的"最小正整數解"不再是隻關注ax+by=c兩個解x,y中的任意一個,而是關注了|x|+|y|的值。其實學過這類函數的同學可以畫個W=|x|+|y|圖像試試,通過不斷平移,你會發現最小的整點一定是最靠近直線與座標軸交點的地方。因此我們就先解決ax+by=c對於x的最小正整數解,再解決對於y的最小正整數解,按照他的排序要求,找到最小的那個即可。

AC代碼:


#include<iostream>
#include<cstdio>
#define ll long long
using namespace std;
ll exgcd(ll a,ll b,ll &x,ll &y){
	ll d;
	if(b){d=exgcd(b,a%b,y,x);y-=a/b*x;return d;}
	x=1;y=0;return a;
}
ll ab(ll x){
	return x>0?x:-x;
}
ll w1,w2,c;
void work(){
	ll d,anx,any,min1=2147483647,min2=2147483647,x,y;
	d=exgcd(w1,w2,anx,any);anx=anx*c/d;any=any*c/d;
	x=anx;y=any;
	anx=(anx%(w2/d)+w2/d)%(w2/d);
	any=any-(anx-x)/(w2/d)*(w1/d);
	min1=ab(anx)+ab(any);min2=anx*w1+any*w2;
	x=anx;y=any;
	any=(any%(w1/d)+w1/d)%(w1/d);
	anx=anx-(any-y)/(w1/d)*(w2/d);
	if(min1>ab(anx)+ab(any)){
		x=anx;y=any;
	}
	if(min1==ab(anx)+ab(any)){
		if(min2>anx*w1+any*w2){
			x=anx;y=any;
		}
	}
	printf("%lld %lld\n",ab(x),ab(y));
}
int main(){
	while(1){
		scanf("%lld%lld%lld",&w1,&w2,&c);
		if(w1==0&&w2==0&&c==0)return 0;
		work();
	}
	return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章