Count the string 【hdu-3336】【KMP】

Count the string

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10896    Accepted Submission(s): 5072


Problem Description
It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: "abab"
The prefixes are: "a", "ab", "aba", "abab"
For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.
 

Input
The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.
 

Output
For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.
 

Sample Input
1 4 abab
 

Sample Output
6



代碼如下:


#include<cstdio>
#include<cstring>

char P[200005];
int Next[200005];

int main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		int n;
		scanf("%d",&n);
		scanf("%s",P);
		int i,k=0;
		memset(Next,0,sizeof(Next));
		int sum=0;
		Next[0]=0;
		for(i=1;i<n;i++){
			while(k>0&&P[i]!=P[k])
				k=Next[k-1];
			if(P[i]==P[k]){
				sum=(sum+1)%10007;
				k++;
			}
			Next[i]=k;
		}
		
		sum=(sum+n)%10007;
		printf("%d\n",sum);
		
	}
	
	return 0;
}




發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章