Number Sequence 【hdu-1711】【KMP】

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 29376    Accepted Submission(s): 12350


Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

Sample Input
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 

Sample Output
6 -1


題解:KMP算法的基本應用。如果對KMP還不是很瞭解,可以看這篇博文:點擊打開鏈接


代碼如下:


#include<cstdio>
#include<cstring>

int a[1000005],b[10005];
int Next[10005];
int n,m;
int pos;

void Get_Next(){
	int i,k=0;
	Next[0]=0;
	for(i=1;i<m;i++){
		
		while(k>0&&b[i]!=b[k]){
			k=Next[k-1];
		}
		if(b[k]==b[i])
			k++;
		Next[i]=k;	
	}
	
}

void Kmp(){
	int i,k=0;
	
	for(i=0;i<n;i++){
		
		while(k>0&&a[i]!=b[k]){
			k=Next[k-1];
		}
		if(b[k]==a[i])
			k++;
		if(k==m){
			pos=i-m+1;
			break;
		}
	}
	if(pos==-1) pos=-2;
	
}

int main()
{
	int T;
	scanf("%d",&T);
	while(T--){
		scanf("%d%d",&n,&m);
		memset(Next,0,sizeof(Next));
		for(int i=0;i<n;i++)
			scanf("%d",&a[i]);
		
		for(int i=0;i<m;i++)
			scanf("%d",&b[i]);
		
		pos=-1;
		
		Get_Next();
		Kmp();
		
		printf("%d\n",pos+1);
		
	}
	
	
	return 0;
}




發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章