HDU 1856

Time Limit: 1000MS   Memory Limit: 102400KB   64bit IO Format: %I64d & %I64u

 Status

Description

Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements. 

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way. 
 

Input

The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
 

Output

The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep. 
 

Sample Input

4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8
 

Sample Output

4 2
題意:找互相認識的最多的人羣。

思路:基礎並查集。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 10240000;
int num[maxn];
int f[maxn];
int Find(int x)
{
    return x == f[x]?x:f[x] = Find(f[x]);
}
void Union(int x,int y)
{
    int xx = Find(x);
    int yy = Find(y);
    if(xx != yy)
    {
        f[xx] = yy;
        num[yy]+=num[xx];
    }
}
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        for(int i = 0;i <= 10000000;i++)
        {
            f[i] = i;
            num[i] = 1;
        }
        for(int i = 0;i < n;i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            Union(x,y);
        }
        int maxx = 0;
        for(int i = 0;i <= 10000000;i++)
        {
            maxx = max(maxx,num[i]);
        }
        printf("%d\n",maxx);
    }
    return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章