典型揹包問題

Bone Collector

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 10199 Accepted Submission(s): 3905


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
Bone <wbr>Collector(hdu <wbr>2602)


Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output

One integer per line representing the maximum of the total value (this number will be less than 231).

Sample Input
5 10 
1 2 3 4 
5 5 4 3 2 1

Sample Output
14

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;

#define maxn(a,b) (a>b?a:b)
int dp[1001],vol[1001],val[1001];
int main()
{
    int t,n,i,j,v;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&v);
        for(i=1;i<=n;i++)
            scanf("%d",&val[i]);
        for(i=1;i<=n;i++)
            scanf("%d",&vol[i]);
        memset(dp,0,sizeof(dp));
        for(i=1;i<=n;i++)
            for(j=v;j>=vol[i];j--)
                dp[j]=maxn(dp[j-vol[i]]+val[i],dp[j]);
        printf("%d\n",dp[v]);
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章