POJ3352(Road Construction)

Road Construction

Description

It’s almost summer time, and that means that it’s almost summer construction time! This year, the good people who are in charge of the roads on the tropical island paradise of Remote Island would like to repair and upgrade the various roads that lead between the various tourist attractions on the island.

The roads themselves are also rather interesting. Due to the strange customs of the island, the roads are arranged so that they never meet at intersections, but rather pass over or under each other using bridges and tunnels. In this way, each road runs between two specific tourist attractions, so that the tourists do not become irreparably lost.

Unfortunately, given the nature of the repairs and upgrades needed on each road, when the construction company works on a particular road, it is unusable in either direction. This could cause a problem if it becomes impossible to travel between two tourist attractions, even if the construction company works on only one road at any particular time.

So, the Road Department of Remote Island has decided to call upon your consulting services to help remedy this problem. It has been decided that new roads will have to be built between the various attractions in such a way that in the final configuration, if any one road is undergoing construction, it would still be possible to travel between any two tourist attractions using the remaining roads. Your task is to find the minimum number of new roads necessary.

Input

The first line of input will consist of positive integers n and r, separated by a space, where 3 ≤ n ≤ 1000 is the number of tourist attractions on the island, and 2 ≤ r ≤ 1000 is the number of roads. The tourist attractions are conveniently labelled from 1 to n. Each of the following r lines will consist of two integers, v and w, separated by a space, indicating that a road exists between the attractions labelled v and w. Note that you may travel in either direction down each road, and any pair of tourist attractions will have at most one road directly between them. Also, you are assured that in the current configuration, it is possible to travel between any two tourist attractions.

Output

One line, consisting of an integer, which gives the minimum number of roads that we need to add.

Sample Input

Sample Input 1
10 12
1 2
1 3
1 4
2 5
2 6
5 6
3 7
3 8
7 8
4 9
4 10
9 10

Sample Input 2
3 3
1 2
2 3
1 3
Sample Output

Output for Sample Input 1
2

Output for Sample Input 2
0

思路

給定一張無向圖,問最少要加多少條邊才能變成邊雙連通圖。該題沒有重邊,如果有重邊下面的代碼是不行的。Tarjan + 縮點。

  1. 先對該無向圖進行Tarjan生成一個時間序
  2. 時間序相同的肯定是在一個連通分量中,進行縮點
  3. 最後要加入的邊就是(度爲1的縮點個數+1)/ 2。
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <stack>
#include <cmath>
using namespace std;
const int maxn = 1005;
struct edge{
	int from;
	int to;
	int next;
}e[maxn<<1];
stack<int>s;
int dfn[maxn];
int low[maxn];
int d[maxn];
int head[maxn];
int vis[maxn];
int bcc[maxn];
int res,cnt,tot;
inline void addedge(int x,int y)
{
	e[tot].from = x;
	e[tot].to = y;
	e[tot].next = head[x];
	head[x] = tot++;
}
inline void clear_set()
{
	tot = cnt = res = 0;
	memset(head,-1,sizeof(head));
	memset(vis,false,sizeof(vis));
	memset(bcc,0,sizeof(bcc));
	memset(dfn,0,sizeof(dfn));
	memset(low,0,sizeof(low));
	memset(d,0,sizeof(d));
	while(!s.empty())	s.pop();
}
inline void tarjan(int x,int fx)
{
	low[x] = dfn[x] = ++cnt;
	s.push(x);vis[x] = true;
	for(int i = head[x];~i;i = e[i].next){
		int y = e[i].to;
		if(y == fx)		continue;
		if(!dfn[y]){
			tarjan(y,x);
			low[x] = min(low[x],low[y]);
		}
		else if(vis[y]){
			low[x] = min(low[x],dfn[y]);
		}
	}
	if(low[x] == dfn[x]){
		res++;
		while(true){
			int t = s.top();
			s.pop();
			vis[t] = false;
			bcc[t] = res;
			if(t == x)	break;
		}
	}
}
int main()
{
	int n,m;
	while(~scanf("%d%d",&n,&m)){
		clear_set();
		int x,y;
		for(int i = 0;i < m;i++){
			scanf("%d%d",&x,&y);
			addedge(x,y);	addedge(y,x); 
		}
		for(int i = 1;i <= n;i++){
			if(!dfn[i]){
				tarjan(i,-1);
			}
		}
		for(int i = 0;i < tot;i++){
			x = e[i].from;
			y = e[i].to;
			if(bcc[x] != bcc[y]){
				d[bcc[x]]++;
			}
		}
		int ans = 0;
		for(int i = 1;i <= res;i++){
			if(d[i] == 1){
				ans++;
			}
		}
		printf("%d\n",(ans+1)/2);
	}
	return 0;	
}

願你走出半生,歸來仍是少年~

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章