HDU - 4027 Can you answer these queries? (線段樹,坑點太多,開方操作)

Problem Description
A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.

Notice that the square root operation should be rounded down to integer.
 

Input
The input contains several test cases, terminated by EOF.
  For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
  The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 263.
  The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
  For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.
 

Output
For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.
 

Sample Input
10 1 2 3 4 5 6 7 8 9 10 5 0 1 10 1 1 10 1 1 5 0 5 8 1 4 8
 

Sample Output
Case #1: 19 7 6
 
題意:先輸入一寫數字,然後有兩種操作,0操作就是把這個區間內數字都開方,1操作就是查詢這個區間的和

1操作大家都會,0操作因爲開放後的和相加並不等於原來的值,比如sqrt(10)!=sqrt(5)+sqrt(5)所以我們每次都找到子節點,然後pushup回去。

坑點:1、題目說要向下取整,然而直接用sqrt函數就可以。

2、有一種情況不考慮就要超時,如果子節點就是1的話就不用考慮,當時我看別人博客sum[rt]==r-l+1有點懵,然後才懂r-l+1是區間長度,那麼也就代表這個區間每個數都是1。1再怎麼開放也都一樣,這個可以直接return,節約時間

3、給你的數據有可能前一個數比後一個大要自己判斷

#include<stdio.h>
#include<math.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define ll long long
const int maxn=100000+5;
ll sum[maxn<<2];
void pushup(int rt)
{
    sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
void build(int l,int r,int rt)
{
    if(l==r)
    {
        scanf("%lld",&sum[rt]);
        return ;
    }
    int m=(r+l)>>1;
    build(l,m,rt<<1);
    build(m+1,r,rt<<1|1);
    pushup(rt);
}
void update(int L,int R,int l,int r,int rt)
{
    if(l==r)
    {
        sum[rt]=sqrt(sum[rt]);
        return;
    }
    if(L<=l&&R>=r&&sum[rt]==r-l+1)
        return;
    int m=(l+r)>>1;
    if(L<=m) update(L,R,l,m,rt<<1);
    if(R>m) update(L,R,m+1,r,rt<<1|1);
    pushup(rt);
}
ll query(int L,int R,int l,int r,int rt)
{
    if(L<=l&&r<=R)
        return sum[rt];
    int m=(l+r)>>1;
    ll ans=0;
    if(L<=m)
        ans+=query(L,R,l,m,rt<<1);
    if(R>m)
        ans+=query(L,R,m+1,r,rt<<1|1);
    return ans;
}
int main()
{
    int n,m,t,x,y;
    int casee=0;
    while(~scanf("%d",&n))
    {
        build(1,n,1);
        scanf("%d\n",&m);
        printf("Case #%d:\n",++casee);
        for(int i=0; i<m; i++)
        {
            scanf("%d%d%d",&t,&x,&y);
            int a=min(x,y),b=max(x,y);
            if(t==0)
                update(a,b,1,n,1);
            else
                printf("%lld\n",query(a,b,1,n,1));
        }
        printf("\n");
    }
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章