zoj 3726& hdu 4791 Alice's Print Service

Alice's Print Service

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1298    Accepted Submission(s): 306


Problem Description
Alice is providing print service, while the pricing doesn't seem to be reasonable, so people using her print service found some tricks to save money.
For example, the price when printing less than 100 pages is 20 cents per page, but when printing not less than 100 pages, you just need to pay only 10 cents per page. It's easy to figure out that if you want to print 99 pages, the best choice is to print an extra blank page so that the money you need to pay is 100 × 10 cents instead of 99 × 20 cents.
Now given the description of pricing strategy and some queries, your task is to figure out the best ways to complete those queries in order to save money.
 

Input
The first line contains an integer T (≈ 10) which is the number of test cases. Then T cases follow.
Each case contains 3 lines. The first line contains two integers n, m (0 < n, m ≤ 105 ). The second line contains 2n integers s1, p1 , s2, p2 , ..., sn, pn (0=s1 < s2 < ... < sn ≤ 109 , 109 ≥ p1 ≥ p2 ≥ ... ≥ pn ≥ 0).. The price when printing no less than si but less than si+1 pages is pi cents per page (for i=1..n-1). The price when printing no less than sn pages is pn cents per page. The third line containing m integers q1 .. qm (0 ≤ qi ≤ 109 ) are the queries.
 

Output
For each query qi, you should output the minimum amount of money (in cents) to pay if you want to print qi pages, one output in one line.
 

Sample Input
1 2 3 0 20 100 10 0 99 100
 

Sample Output
0 1000 1000
 

Source
 

題意:給你n個s,p,然後讓你查詢m個s,求最低的打印錢,規則是si如果比si-1大但比si+1小則價格是pi-1。

做法:我是用線段樹+二分做的,先對每個查詢的值用二分求出它所在的價格的點b,然後在線段樹上查詢(b+1,n)上的最小值,兩者比較取小值就是答案。還有一種方法就是先從後dp過來,把最小值保存在當前值中,然後直接二分出位置,然後比較這個點的價格和下一個點的價格,兩者中的小值就是答案。

#include <iostream>
#include <cstdio>
#include <climits>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include <map>
#include<stack>
#include <set>
#include <algorithm>
#include<ctime>
#define esp 1e-6
#define LL long long
#define inf 0x0f0f0f0f
using namespace std;
LL n,m;
LL search2(LL array[], LL n, LL v)
{
    LL left, right, middle;

    left = 1, right = n;

    while (left <= right)
    {
        middle = (left + right) / 2;
        if (array[middle] > v)
        {
            right = middle - 1;
        }
        else if (array[middle] < v)
        {
            left = middle + 1;
        }
        else
        {
            return middle;
        }
    }

    return right;
}
struct Node
{
    LL left,right;
    LL sum;
};
Node T[100005<<2];
void build(LL cur,LL l,LL r)
{
    T[cur].left=l;
    T[cur].right=r;
    T[cur].sum=(1LL<<60);
    if(l!=r)
    {
        build(2*cur,l,(l+r)/2);
        build(2*cur+1,(l+r)/2+1,r);
    }
    else
    {
        return;
    }
}
LL query(LL cur,LL l,LL r)
{
    if(l<=T[cur].left&&T[cur].right<=r)
        return T[cur].sum;
    else
    {
        LL ans=(1LL<<60);
        if(l<=(T[cur].left+T[cur].right)/2)
            ans=min(ans,query(2*cur,l,r));
        if(r>(T[cur].left+T[cur].right)/2)
            ans=min(ans,query(2*cur+1,l,r));
        return ans;
    }
}
void change(LL cur,LL x,LL del)
{
    if(T[cur].left==T[cur].right)
        T[cur].sum=del;
    else
    {
        if(x<=(T[cur].left+T[cur].right)/2)
            change(2*cur,x,del);
        if(x>(T[cur].left+T[cur].right)/2)
            change(2*cur+1,x,del);
        T[cur].sum=min(T[2*cur].sum,T[2*cur+1].sum);
    }
}
struct wupin
{
    LL s;
    LL p;
}w[100005];
int main()
{
    LL t;
    LL i,j;
    LL ans;
    scanf("%I64d",&t);
    while(t--)
    {
        scanf("%I64d%I64d",&n,&m);
        LL ss[100005];
        build(1,1,n);
        for(i=1;i<=n;i++)
        {
            scanf("%I64d%I64d",&w[i].s,&w[i].p);
            ss[i]=w[i].s;
            change(1,i,w[i].s*w[i].p);
        }
        while(m--)
        {
            LL a,b;
            scanf("%I64d",&a);
            b=search2(ss,n,a);
            ans=a*w[b].p;
            if(b+1<=n)
            ans=min(ans,query(1,b+1,n));
            printf("%I64d\n",ans);
        }
    }
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章