HDU2602 01揹包(裸)模板題

                      HDU2602---Bone Collector

 

Problem Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 

Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output

One integer per line representing the maximum of the total value (this number will be less than 231).
 

Sample Input

1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output

14

 

二維數組:

//#define _CRT_SECURE_NO_WARNINGS//防止一些函數VS認定不安全而錯誤
#pragma warning(disable:4996)//屏蔽4996警告信息
#include <iostream>
#include<conio.h>
#include<time.h>
#include<vector>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<string>

typedef long long ll;
typedef long l;
#define fo(i,begin,end) for(int i=begin;i<end;++i)
#define foo(i,begin,end) for(int i=begin;i>end;--i)
#define clr(a) memset(a,0,sizeof(a))
const int maxn = 1005;
using namespace std;
ll dp[maxn][maxn];
ll val[maxn],vol[maxn];

int main()
{
	//freopen("in.txt", "r", stdin);
	ios::sync_with_stdio;
	int t;
	cin >> t;
	while (t--)
	{
		clr(dp);
		clr(val);
		clr(vol);
		
		int n, v;
		cin >> n >> v;
		fo(i, 1, n+1)
			cin >> val[i];//價值
		fo(i, 1, n+1)
			cin >> vol[i];//體積
		fo(i, 1, n+1)
		{
			fo(j, 0, v + 1)
			{
				if (j < vol[i])
					dp[i][j] = dp[i - 1][j];
				else
					dp[i][j] = max(dp[i - 1][j], dp[i - 1][j - vol[i]] + val[i]);
			}
		}
		cout << dp[n][v]<<endl;
	}
	
	return 0;

	
}

滾動數組

//#define _CRT_SECURE_NO_WARNINGS//防止一些函數VS認定不安全而錯誤
#pragma warning(disable:4996)//屏蔽4996警告信息
#include <iostream>
#include<conio.h>
#include<time.h>
#include<vector>
#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<string>

typedef long long ll;
typedef long l;
#define fo(i,begin,end) for(int i=begin;i<end;++i)
#define foo(i,begin,end) for(int i=begin;i>end;--i)
#define clr(a) memset(a,0,sizeof(a))
const int maxn = 1005;
using namespace std;
ll dp[maxn];//dp[i]表示i體積下能得到的最大值
ll val[maxn],vol[maxn];

int main()
{
	//freopen("in.txt", "r", stdin);
	ios::sync_with_stdio;
	int t;
	cin >> t;
	while (t--)
	{
		clr(dp);
		clr(val);
		clr(vol);
		
		int n, v;
		cin >> n >> v;
		fo(i, 1, n+1)
			cin >> val[i];//價值
		fo(i, 1, n+1)
			cin >> vol[i];//體積
		fo(i, 1, n+1)
		{
			foo(j,v,vol[i]-1)
			{
					dp[j] = max(dp[j], dp[j - vol[i]] + val[i]);
			}
			
		}
		cout << dp[v]<<endl;
	}
	
	return 0;

	
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章