POJ-1308

Is It A Tree?
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 33890   Accepted: 11479

Description

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 

There is exactly one node, called the root, to which no directed edges point. 
Every node except the root has exactly one edge pointing to it. 
There is a unique sequence of directed edges from the root to each node. 
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not. 

In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output

For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input

6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1

Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.

Source

North Central North America 1997

一開始我並沒想到並查集-只想到了以前在南陽ACM做過的吝嗇的國度--結果走歪了

最後再網上找了一個並查集代碼很簡潔的 就拿過來自己用了

以前做的並查集代碼還沒這個簡潔呢

AC情況:


#include<stdio.h>  
#define N 1000  
# define max(a,b) (a)>(b)?(a):(b)  
int p[N],k,i,a,b,flag,sum,M;  
int find(int x)  
{  
	int y=x;
    if(!p[x]) p[x]=x;  
    else while(x!=p[x]) x=p[x];  
    return p[y]=x;  
}  
void Link(int x,int y)  
{  
    int xx=x,yy=y,fx=0,fy=0;  
    if(!p[x]) p[x]=x;
	else while(x!=p[x]&&++fx)x=p[x];
    p[xx]=x;
    if(!p[y]) p[y]=y;  
    else while(y!=p[y]&&++fy)y=p[y];  
	p[yy]=y;
    if(x==y)return;  
    if(fx<fy) p[x]=y;  
    else p[y]=x;  
	
} 
int main()  
{  
    char A[][5]={"\0"," not"};  
    //freopen("ASDFG.txt","r",stdin);  
    while(1)  
    {  
        while(scanf("%d %d",&a,&b)!=EOF&&a&&b)  
        {  
            if(a==-1||b==-1)return 0;   
            if(find(a)==find(b)) flag=1;  
            if(!flag)Link(a,b);  
            a=max(a,b);  
            M=max(a,M);  
        }  
        for(i=1,sum=0,M++; i<M; i++)  
        {  
            if(p[i]==i)sum++;  
            p[i]=0;  
        }  
        flag=(sum>1||flag);  
        printf("Case %d is%s a tree.\n",++k,A[flag]);  
        flag=M=0;  
    }  
    return 0;  
} 


代碼C:

#include<stdio.h>
#define N 1000
# define max(a,b) (a)>(b)?(a):(b)
int p[N],k,i,a,b,flag,sum,M;
int find(int x)
{
    while(x!=p[x]) x=p[x];
    return x;
}
int Link(int x,int y)
{
    int fy,fx;
    fy=find(y);
    fx=find(x);
    if(fy!=fx)  p[fy]=fx;
}
int main()
{
    char A[][5]={"\0"," not"};
    //freopen("ASDFG.txt","r",stdin);
    while(1)
    {
        while(scanf("%d %d",&a,&b)!=EOF&&a&&b)
        {
            if(a==-1||b==-1)return 0;
            if(!p[a]) p[a]=a;
            if(!p[b]) p[b]=b;
            if(find(a)==find(b)) flag=1;
            if(!flag)Link(a,b);
            a=max(a,b);
            M=max(a,M);
        }
        for(i=1,sum=0,M++; i<M; i++)
        {
            if(p[i]==i) sum++;
            p[i]=0;
        }
        flag=(sum>1||flag);
        printf("Case %d is%s a tree.\n",++k,A[flag]);
        flag=M=0;
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章