[动态规划]UVA 507 - Jill Rides Again


  Jill Rides Again 

Jill likes to ride her bicycle, but since the pretty city of Greenhills where she lives has grown, Jill often uses the excellent public bus system for part of her journey. She has a folding bicycle which she carries with her when she uses the bus for the first part of her trip. When the bus reaches some pleasant part of the city, Jill gets off and rides her bicycle. She follows the bus route until she reaches her destination or she comes to a part of the city she does not like. In the latter event she will board the bus to finish her trip.


Through years of experience, Jill has rated each road on an integer scale of ``niceness.'' Positive niceness values indicate roads Jill likes; negative values are used for roads she does not like. There are not zero values. Jill plans where to leave the bus and start bicycling, as well as where to stop bicycling and re-join the bus, so that the sum of niceness values of the roads she bicycles on is maximized. This means that she will sometimes cycle along a road she does not like, provided that it joins up two other parts of her journey involving roads she likes enough to compensate. It may be that no part of the route is suitable for cycling so that Jill takes the bus for its entire route. Conversely, it may be that the whole route is so nice Jill will not use the bus at all.


Since there are many different bus routes, each with several stops at which Jill could leave or enter the bus, she feels that a computer program could help her identify the best part to cycle for each bus route.

Input 

The input file contains information on several bus routes. The first line of the file is a single integer b representing the number of route descriptions in the file. The identifier for each route (r) is the sequence number within the data file, $1 \le r \le b$. Each route description begins with the number of stops on the route: an integer s$2 \le s \le 20,000$ on a line by itself. The number of stops is followed by s - 1 lines, each line i ( $1 \le i < s$) is an integer ni representing Jill's assessment of the niceness of the road between the two stops i andi+1.

Output 

For each route r in the input file, your program should identify the beginning bus stop i and the ending bus stop j that identify the segment of the route which yields the maximal sum of niceness, m= ni+ni+1+...+nj-1. If more than one segment is maximally nice, choose the one with the longest cycle ride (largest j-i). To break ties in longest maximal segments, choose the segment that begins with the earliest stop (lowest i). For each route r in the input file, print a line in the form:


The nicest part of route r is between stops i and j


However, if the maximal sum is not positive, your program should print:


Route r has no nice parts

Sample Input 

3
3
  -1
   6
10
   4
  -5
   4
  -3
   4
   4
  -4
   4
  -5
4
  -2
  -3
  -4

Sample Output 

The nicest part of route 1 is between stops 2 and 3
The nicest part of route 2 is between stops 3 and 9
Route 3 has no nice parts

题意:题目虽然很长,但是题意比较清晰,就是给出一段数字,求这段数字的最大连续子串和。但是注意的是在值相等的情况下,优先选择距离最长的。

思路:很明显的动态规划的题目,状态转移方程:sum[i] = max{sum[i-1]+a[i],a[i]}

#include<iostream>

using namespace std;

int arry[20010];

int main()
{
    int n,it;
    cin>>n;
    for(it=1;it<=n;it++)
        {
            int num;
            cin>>num;
            for(int i=1;i<num;i++)
                {
                    cin>>arry[i];
                }
            int max=arry[1],sum=arry[1];
            int left=1,right=1,cnt=1;
            for(int i=2;i<num;i++)
                {
                    if(sum<0)
                        {
                            sum=0;
                            cnt=i;
                        }
                    sum=sum+arry[i];
                    if(sum>max||(sum==max&&i-cnt>right-left))
                        {
                            max=sum;
                            left=cnt;
                            right=i;
                        }
                }
            if(max<=0) cout<<"Route "<<it<<" has no nice parts"<<endl;
            else cout<<"The nicest part of route "<<it<<" is between stops "<<left<<" and "<<right+1<<endl;
        }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章