2014ACM多校訓練4 HDOJ 4902 Nice boat

題目:

Nice boat

Time Limit: 30000/15000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 464    Accepted Submission(s): 219


Problem Description
There is an old country and the king fell in love with a devil. The devil always asks the king to do some crazy things. Although the king used to be wise and beloved by his people. Now he is just like a boy in love and can’t refuse any request from the devil. Also, this devil is looking like a very cute Loli.

Let us continue our story, z*p(actually you) defeat the 'MengMengDa' party's leader, and the 'MengMengDa' party dissolved. z*p becomes the most famous guy among the princess's knight party. 

One day, the people in the party find that z*p has died. As what he has done in the past, people just say 'Oh, what a nice boat' and don't care about why he died.

Since then, many people died but no one knows why and everyone is fine about that. Meanwhile, the devil sends her knight to challenge you with Algorithm contest.

There is a hard data structure problem in the contest:

There are n numbers a_1,a_2,...,a_n on a line, everytime you can change every number in a segment [l,r] into a number x(type 1), or change every number a_i in a segment [l,r] which is bigger than x to gcd(a_i,x) (type 2).

You should output the final sequence.
 

Input
The first line contains an integer T, denoting the number of the test cases.
For each test case, the first line contains a integers n.
The next line contains n integers a_1,a_2,...,a_n separated by a single space.
The next line contains an integer Q, denoting the number of the operations.
The next Q line contains 4 integers t,l,r,x. t denotes the operation type.

T<=2,n,Q<=100000
a_i,x >=0
a_i,x is in the range of int32(C++)
 

Output
For each test case, output a line with n integers separated by a single space representing the final sequence.
Please output a single more space after end of the sequence
 

Sample Input
1 10 16807 282475249 1622650073 984943658 1144108930 470211272 101027544 1457850878 1458777923 2007237709 10 1 3 6 74243042 2 4 8 16531729 1 3 4 1474833169 2 1 8 1131570933 2 7 9 1505795335 2 3 7 101929267 1 4 10 1624379149 2 2 8 2110010672 2 6 7 156091745 1 2 5 937186357
 

Sample Output
16807 937186357 937186357 937186357 937186357 1 1 1624379149 1624379149 1624379149
 

傳送門:點擊打開鏈接
大致題意:

操作1區間更新,[l,r]區間元素更新爲x,操作2,區間更新,[1,r]區間元素如果大於x,更新爲與x的最大公約數。

解題思路:

線段樹+lazy,操作1需要使用lazy標記,操作2,找到指定區間直接更新滿足條件的即可。

代碼:

#include <cstdio>
#include <cstring>
#include <algorithm>
using  namespace std;

const int MAXN =  1e5;
typedef  long long lint;
struct SegmentTree
{
    int set;
};
SegmentTree sg[MAXN<<2];
int t, n, q, tp;

void pushdown(int i)
{
    if(-1 != sg[i].set)
    {
        sg[i+i].set = sg[i+i+1].set = sg[i].set;
        sg[i].set = -1;
    }
}

int gcd(int a, int b)
{
    int h;
    while(b)
    {
        h = a % b;
        a = b;
        b = h;
    }
    return a;
}

void build_tree(int l, int r, int i)
{
    if(l == r)
    {
        scanf("%d", &sg[i].set);
        return;
    }
    sg[i].set = -1;
    int mid = (l+r) >> 1;
    build_tree(l, mid, i+i);
    build_tree(mid+1, r, i+i+1);
}

void update(int i, int x)
{
    if(-1 != sg[i].set)
    {
        if(sg[i].set > x)
            sg[i].set = gcd(sg[i].set, x);
        return ;
    }
    update(i+i, x);
    update(i+i+1, x);
}

void update_range1(int L, int R, int l, int r, int i, int x)
{
    if(L <= l && r <= R)
    {
        sg[i].set = x;
        return;
    }
    pushdown(i);
    int mid = (l+r) >> 1;
    if(L <= mid) update_range1(L, R, l, mid, i+i, x);
    if(R >   mid) update_range1(L, R, mid+1, r, i+i+1, x);
}

void update_range2(int L, int R, int l, int r, int i, int x)
{
    if(L<= l && r <= R)
    {
        update(i, x);
        return;
    }
    pushdown(i);
    int mid = (l+r) >> 1;
    if(L <= mid) update_range2(L, R, l, mid, i+i, x);
    if(R >   mid) update_range2(L, R, mid+1, r, i+i+1, x);
}

void query(int L, int R, int l, int r, int i)
{
    if(l == r)
    {
        printf("%d ", sg[i].set);
        return;
    }
    pushdown(i);
    int mid = (l+r) >> 1;
    if(L <= mid) query(L, R, l, mid, i+i);
    if(R >   mid) query(L, R, mid+1, r, i+i+1);
}

void show()
{
    for(int i =1; i < 3*n; ++i)
        printf("%d %d\n", i, sg[i].set);
    printf("\n");
}

int main()
{
    #ifndef ONLINE_JUDGE
    freopen("Ain.txt", "r", stdin);
    #endif
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d", &n);
        build_tree(1, n, 1);
        scanf("%d", &q);
        while(q--)
        {
            int l, r, x;
            scanf("%d", &tp);
            switch(tp)
            {
                case 1:
                {
                    scanf("%d%d%d", &l, &r, &x);
                    update_range1(l, r, 1, n, 1, x);
                    break;
                }
                case 2:
                {
                    scanf("%d%d%d", &l, &r, &x);
                    update_range2(l, r, 1, n, 1, x);
                    break;
                }
            }
        //    show();
        }
        query(1, n, 1, n, 1);
        printf("\n");
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章