Bzoj 1619 [Usaco2008 Nov]Guarding the Farm 保衛牧場

Description

The farm has many hills upon which Farmer John would like to place guards to ensure the safety of his valuable milk-cows. He wonders how many guards he will need if he wishes to put one on top of each hill. He has a map supplied as a matrix of integers; the matrix has N (1 < N <= 700) rows and M (1 < M <= 700) columns. Each member of the matrix is an altitude H_ij (0 <= H_ij <= 10,000). Help him determine the number of hilltops on the map. A hilltop is one or more adjacent matrix elements of the same value surrounded exclusively by either the edge of the map or elements with a lower (smaller) altitude. Two different elements are adjacent if the magnitude of difference in their X coordinates is no greater than 1 and the magnitude of differences in their Y coordinates is also no greater than 1.

農夫JOHN的農夫上有很多小山丘,他想要在那裏佈置一些保鏢(……)去保衛他的那些相當值錢的奶牛們。 他想知道如果在一座小山丘上佈置一名保鏢的話,他總共需要招聘多少名保鏢。他現在手頭有一個用數字矩陣來表示地形的地圖。這個矩陣有N行(1 < N < = 100)和M列( 1 < M < = 70) 。矩陣中的每個元素都有一個值H_ij(0 < = H_ij < =10,000)來表示該地區的海拔高度。請你幫助他統計出地圖上到底有多少個小山丘。 小山丘的定義是:若地圖中一個元素所鄰接的所有元素都比這個元素高度要小(或它鄰接的是地圖的邊界),則該元素和其周圍所有按照這樣順序排列的元素的集合稱爲一個小山丘。這裏鄰接的意義是:若一個元素與另一個橫座標縱座標和它的橫縱座標相差不超過1,則稱這兩個元素鄰接。 問題名稱:guard 輸入格式: 第一行:兩個由空格隔開的整數N和M 第二行到第N+1行:第I+1行描述了地圖上的第I行,有M個由空格隔開的整數:H_ij.

Input

  • Line 1: Two space-separated integers: N and M
  • Lines 2..N+1: Line i+1 describes row i of the matrix with M space-separated integers: H_ij

Output

  • Line 1: A single integer that specifies the number of hilltops

Sample Input

8 7
4 3 2 2 1 0 1
3 3 3 2 1 0 1
2 2 2 2 1 0 0
2 1 1 1 1 0 0
1 1 0 0 0 1 0
0 0 0 1 1 1 0
0 1 2 2 1 1 0

0 1 1 1 2 1 0

Sample Output

3

HINT

三個山丘分別是:左上角的高度爲4的方格,右上角的高度爲1的方格,還有最後一行中高度爲2的方格.

Key To Problem

算是比較水的bfs吧,還是直接看代碼好了

Code

#include <queue>
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#define N 710
using namespace std;
struct node
{
    int x,y,s;
};
node Edge[N*N];
int n,m,tot;
int map[N][N];
bool used[N][N];
int dir[8][2]={
    0,1,
    1,0,
    -1,0,
    0,-1,
    1,-1,
    -1,1,
    -1,-1,
    1,1
};

bool cmp(node a,node b)
{
    return a.s>b.s;
}

bool is(int x,int y)
{
    if(x<=0||x>n||y<=0||y>m)
        return 1;
    return 0;
}

void bfs(node u)
{
    used[u.x][u.y]=true;
    queue<node>Q;
    Q.push(u);
    while(!Q.empty())
    {
        node k=Q.front();
        Q.pop();
        for(int i=0;i<8;i++)
        {
            int xx=dir[i][0]+k.x;
            int yy=dir[i][1]+k.y;
            if(!map[xx][yy]||used[xx][yy]||is(xx,yy))
                continue;
            if(map[xx][yy]>map[k.x][k.y])
                continue;
            used[xx][yy]=true;
            node p;
            p.x=xx,p.y=yy;
            Q.push(p);
        }
    }
}

int main()
{
    cin>>n>>m;
    for(int i=1;i<=n;i++)
    {
        for(int j=1;j<=m;j++)
        {
            scanf("%d",&map[i][j]);
            tot++;
            Edge[tot].x=i,Edge[tot].y=j,Edge[tot].s=map[i][j];
        }
    }
    sort(Edge+1,Edge+tot+1,cmp);
    int ans=0;
    for(int i=1;i<=n*m;i++)
    {
        node k=Edge[i];
        if(!map[k.x][k.y]) break;
        if(!used[k.x][k.y])
            bfs(k),ans++;
    }
    cout<<ans<<endl;
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章