【Poj1703】Find them, Catch them(關係並查集)

Find them, Catch them
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 42064   Accepted: 12936

Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

Source


關係並查集

#include<cstdio>
#include<iostream>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
const int N = 100000+10;
int f[N],rank[N];
int n,m;
void init() {
	for(int i=1; i<=n; i++) {
		f[i]=i;
		rank[i]=0;
	}
}
int find(int x) {
	if(x==f[x]) return f[x];
	int fa=f[x];
	f[x] = find(f[x]);  //路徑壓縮
	rank[x] = (rank[x]+rank[fa])&1;
	return f[x];
}

void Union(int x,int y) {
	int a=find(x), b=find(y);
	if(a==b) return ;
	f[b] = a;
	rank[b] = (rank[x]-rank[y]+1)&1;
}
int main() {
	int T;
	scanf("%d",&T);
	while(T--) {
		scanf("%d%d",&n,&m);
		init();
		char ch;
		int a,b;
		while(m--) {
			getchar();
			scanf("%c%d%d",&ch,&a,&b);
			if(ch=='D') {
				Union(a,b);
			} else {
				int fa=find(a),fb=find(b);
				if(fa==fb) {
					if(rank[a]==rank[b])
						printf("In the same gang.\n");
					else
						printf("In different gangs.\n");
				} else
					printf("Not sure yet.\n");
			}
		}
	}
	return 0;
}




發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章