hdu 4986 Arc of Dream 矩陣快速冪求遞推式

Arc of Dream

Time Limit: 2000/2000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 2534    Accepted Submission(s): 777


Problem Description
An Arc of Dream is a curve defined by following function:

where
a0 = A0
ai = ai-1*AX+AY
b0 = B0
bi = bi-1*BX+BY
What is the value of AoD(N) modulo 1,000,000,007?
 

Input
There are multiple test cases. Process to the End of File.
Each test case contains 7 nonnegative integers as follows:
N
A0 AX AY
B0 BX BY
N is no more than 1018, and all the other integers are no more than 2×109.
 

Output
For each test case, output AoD(N) modulo 1,000,000,007.
 

Sample Input
1 1 2 3 4 5 6 2 1 2 3 4 5 6 3 1 2 3 4 5 6
 

Sample Output
4 134 1902
 

Author
Zejun Wu (watashi)
 

Source
 

Recommend
zhuyuanchen520   |   We have carefully selected several similar problems for you:  5197 5196 5195 5194 5193 
 

先將式子轉化爲遞推式, Sn = Sn-1+an-1*bn-1, 其中an*bn也是遞推式an*bn=ax*bx*an-1*bn-1+ax*by*an-1+ay*bx*bn-1+ay*by。

遞推式可以轉爲矩陣快速冪O(n^3logk)複雜度,n*n的矩陣的k次冪

[sn an-1*bn-1 an-1 bn-1 1] = [ sn-1 an-2*an-2 an-2 bn-2 1]* [  [1 ax*bx ax*by ay*bx ay*by]  [0 ax*bx ax*by ay*bx ay*by] [0 0 ax 0 ay] [0 0 0 bx by] [0 0 0 0 1]] //共5列

前兩個矩陣爲1*5,最後個矩陣爲5*5.根據遞推公式很容易列出第一個矩陣每一項對應的列的係數是什麼,從而得到最後一個矩陣。

複雜度是O(5*5*5*logn)


#include <iostream>
#include <cstring>
#include <cstdio>
#include <vector>
#include <algorithm>

using namespace std;

#define M 1000000007

typedef unsigned long long ll;
typedef vector<ll> vec;
typedef vector<vec> mat;

mat mul(mat &a, mat &b)
{
    mat c(a.size(), vec(b[0].size()));
    for(int i = 0 ;i < a.size(); i++)
        for(int j = 0; j < b.size(); j++)
        for(int k = 0; k < b[0].size(); k++)
          c[i][k] = (c[i][k]+a[i][j]*b[j][k])%M;

    return c;
}

mat power(mat a, ll n)
{
    mat  b(a.size(), vec(a.size()));
    for(int i = 0; i < a.size(); i++)
        b[i][i] = 1;
    while(n > 0){
        if(n&1) b = mul(b,a);
        a = mul(a, a);
        n >>= 1;
    }
    return b;
}

int main()
{

    ll n;
    ll a0,ax,ay,b0,bx,by;
    while(cin >> n){
        cin >> a0 >> ax>> ay >> b0 >> bx >> by;
        if(!n){
            cout << 0 <<endl;
            continue;
        }

        a0%=M,b0%=M,ax%=M,ay%=M,bx%=M,by%=M;
        mat a(5, vec(5));
        a[0][0] = 1;
        a[1][0] = ax*bx%M,a[1][1] = ax*bx%M;
        a[2][0] = ax*by%M, a[2][1]=ax*by%M,a[2][2] = ax;
        a[3][0] = ay*bx%M, a[3][1]=ay*bx%M,a[3][3] = bx;
        a[4][0] = by*ay%M, a[4][1] = by*ay%M, a[4][2] = ay, a[4][3] = by, a[4][4] = 1;


        a = power(a, n-1);
        mat fir(1, vec(5));
        fir[0][0] = a0*b0%M, fir[0][1] = a0*b0%M, fir[0][2] = a0, fir[0][3] = b0, fir[0][4] = 1;
        mat ans = mul(fir, a);
        cout << ans[0][0] << endl;
    }
    return 0;
}




發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章