EXTENDED LIGHTS OUT【高斯消元】

Description

In an extended version of the game Lights Out, is a puzzle with 5 rows of 6 buttons each (the actual puzzle has 5 rows of 5 buttons each). Each button has a light. When a button is pressed, that button and each of its (up to four) neighbors above, below, right and left, has the state of its light reversed. (If on, the light is turned off; if off, the light is turned on.) Buttons in the corners change the state of 3 buttons; buttons on an edge change the state of 4 buttons and other buttons change the state of 5. For example, if the buttons marked X on the left below were to be pressed,the display would change to the image on the right.

The aim of the game is, starting from any initial set of lights on in the display, to press buttons to get the display to a state where all lights are off. When adjacent buttons are pressed, the action of one button can undo the effect of another. For instance, in the display below, pressing buttons marked X in the left display results in the right display.Note that the buttons in row 2 column 3 and row 2 column 5 both change the state of the button in row 2 column 4,so that, in the end, its state is unchanged.

Note:
1. It does not matter what order the buttons are pressed.
2. If a button is pressed a second time, it exactly cancels the effect of the first press, so no button ever need be pressed more than once.
3. As illustrated in the second diagram, all the lights in the first row may be turned off, by pressing the corresponding buttons in the second row. By repeating this process in each row, all the lights in the first
four rows may be turned out. Similarly, by pressing buttons in columns 2, 3 ?, all lights in the first 5 columns may be turned off.
Write a program to solve the puzzle.

題意:有一個5行6列的大方格,每個小方格里都有一盞燈,當你去改變其中一盞燈的狀態時,它周圍(上下左右)的燈也會改變狀態,即亮着的燈會被關掉,關掉的燈會被打開。爲了使所有的燈都被關掉,問哪些燈需要被改變狀態。

思路:最簡單的高斯消元運用,該題只有唯一解,所有不用考慮其他情況。即每盞燈的狀態是否需要被改變爲方程的一個變元,根據題意列方程組,解出方程組,每個變元相應的解即爲答案。


Input

The first line of the input is a positive integer n which is the number of puzzles that follow. Each puzzle will be five lines, each of which has six 0 or 1 separated by one or more spaces. A 0 indicates that the light is off, while a 1 indicates that the light is on initially.

Output

For each puzzle, the output consists of a line with the string: "PUZZLE #m", where m is the index of the puzzle in the input file. Following that line, is a puzzle-like display (in the same format as the input) . In this case, 1's indicate buttons that must be pressed to solve the puzzle, while 0 indicate buttons, which are not pressed. There should be exactly one space between each 0 or 1 in the output puzzle-like display.

Sample Input

2
0 1 1 0 1 0
1 0 0 1 1 1
0 0 1 0 0 1
1 0 0 1 0 1
0 1 1 1 0 0
0 0 1 0 1 0
1 0 1 0 1 1
0 0 1 0 1 1
1 0 1 1 0 0
0 1 0 1 0 0

Sample Output

PUZZLE #1
1 0 1 0 0 1
1 1 0 1 0 1
0 0 1 0 1 1
1 0 0 1 0 0
0 1 0 0 0 0
PUZZLE #2
1 0 0 1 1 1
1 1 0 0 0 0
0 0 0 1 0 0
1 1 0 1 0 1
1 0 1 1 0 1

<span style="font-size:18px;">#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstring>
#define maxn 35
using namespace std;
int a[maxn][maxn],x[maxn];          //a[]數組存儲方程組的係數,x[]數組存儲每個變元的解
int equ,var;                                    //equ表示方程的個數,var表示解的個數
int Gauss()
{
    int max_r,k,col;
    for(k=0,col=0; k<equ&&col<var; k++,col++)
    {
        max_r=k;
        for(int j=k+1; j<equ; j++)         //尋找該列最大值所在的行
        {
            if(abs(a[j][col])>abs(a[max_r][col]))
                max_r=j;
        }
        if(max_r!=k)                              //如果存在,則進行行交換
        {
            for(int j=col; j<var+1; j++)
                swap(a[k][j],a[max_r][j]);
        }
        for(int i=k+1; i<equ; i++)          //尋找該列有值的行進行合併同類項
        {
            if(a[i][col])
            {
                for(int j=col; j<var+1; j++)
                    a[i][j]^=a[k][j];
            }
        }
    }
    for(int i=var-1; i>=0; i--)                 //求解
    {
        x[i]=a[i][30];
        for(int j=i+1; j<var; j++)
        {
            x[i]^=(a[i][j]&x[j]);
        }
    }
    return 0;
}
void init()
{
    memset(a,0,sizeof(a));
    memset(x,0,sizeof(x));
    equ=30;
    var=30;
    for(int i=0; i<5; i++)
        for(int j=0; j<6; j++)
        {
            int t=i*6+j;
            a[t][t]=1;                                //本身係數爲1
            if(i>0)a[(i-1)*6+j][t]=1;           //與它相關的合法的變元的係數也爲1
            if(i+1<5)a[(i+1)*6+j][t]=1;
            if(j>0)a[i*6+j-1][t]=1;
            if(j+1<6)a[i*6+j+1][t]=1;
        }
}
int main()
{
    int t;
    scanf("%d",&t);
    for(int k=1;k<=t;k++)
    {
        init();
        for(int i=0; i<5; i++)
            for(int j=0; j<6; j++)
            {
                scanf("%d",&a[i*6+j][30]);        //每個變元的最初狀態
            }
        Gauss();
        printf("PUZZLE #%d\n",k);
        for(int i=0; i<5; i++)
            for(int j=0; j<6; j++)
            {
                printf("%d%c",x[i*6+j],j==5?'\n':' '); 
            }
    }
    return 0;
}</span>



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章