hdu2955 dp(揹包)

**

Robberies

**

Problem Description

The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.

For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.

His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.

Input

The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .
Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .

Output

For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints
0 < T <= 100
0.0 <= P <= 1.0
0 < N <= 100
0 < Mj <= 100
0.0 <= Pj <= 1.0
A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

Sample Input

3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05

Sample Output

2
4
6

思路:
這題的樣例出的非常坑,一開始讓人以爲只要概率相加小於P即可。於是將概率放大1000倍,用01揹包來做。直接wa了。
但是被抓的概率不是簡單的直接相加。於是考慮不被抓的概率,假設被抓概率爲p1,p2,於是不被抓的概率爲(1-p1)*(1-p2)。
我們只要求偷掉價值w時不被抓的最大概率。
用dp來做。
dp[i] 表示偷掉w百萬元時不被抓的最大概率。
狀態轉移方程:dp[j]=max(dp[j],dp[j-w[i]*(1-p[i]));

代碼:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N=10005;
double dp[N];
int w[105];double p[105];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        int n;double P;
        scanf("%lf%d",&P,&n);
        int sum=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d%lf",&w[i],&p[i]);
            sum+=w[i];
        }
        for(int i=0;i<=sum;i++)dp[i]=-1;
        dp[0]=1;//不偷錢肯定不被抓
        for(int i=1;i<=n;i++)
        {
            for(int j=sum;j>=w[i];j--){
                dp[j]=max(dp[j],dp[j-w[i]]*(1.0-p[i]));
            }
        }
        for(int j=sum;j>=0;j--){
            if(dp[j]>0&&1-dp[j]<=P)
                {
                printf("%d\n",j);break;
                }
        }
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章