POJ 1463 Strategic game 树形DP

Description

Bob enjoys playing computer games, especially strategic games, but sometimes he cannot find the solution fast enough and then he is very sad. Now he has the following problem. He must defend a medieval city, the roads of which form a tree. He has to put the minimum number of soldiers on the nodes so that they can observe all the edges. Can you help him? 

Your program should find the minimum number of soldiers that Bob has to put for a given tree. 

For example for the tree: 


the solution is one soldier ( at the node 1).

Input

The input contains several data sets in text format. Each data set represents a tree with the following description: 


  • the number of nodes 
  • the description of each node in the following format 
    node_identifier:(number_of_roads) node_identifier1 node_identifier2 ... node_identifiernumber_of_roads 
    or 
    node_identifier:(0) 


The node identifiers are integer numbers between 0 and n-1, for n nodes (0 < n <= 1500);the number_of_roads in each line of input will no more than 10. Every edge appears only once in the input data.

Output

The output should be printed on the standard output. For each given input data set, print one integer number in a single line that gives the result (the minimum number of soldiers). An example is given in the following:

Sample Input

4
0:(1) 1
1:(2) 2 3
2:(0)
3:(0)
5
3:(3) 1 4 2
1:(1) 0
2:(0)
0:(0)
4:(0)

Sample Output

1
2

题意:在一棵树形道路上的结点中布置士兵,每个士兵可以守护与其结点直接相连的边,问最少要布置多少士兵。

分析:每个节点可选择是否布置士兵看守,分别用dp[v][0]和dp[v][1]表示该情况下以v为根节点的子树最少需要布置的士兵数量。

初始状态:dp[v][0]=0;dp[v][1]=1;

非叶节点v:若节点v不布置士兵,则其所有直接相连的子节点都必须布置士兵,所以dp[v][0] += Σdp[u][1](u为v的各子节点);

                    若节点v布置士兵,则其各子树可尽量放最少的士兵数,dp[v][1] +=Σmin(dp[u][0], dp[u][1])。

最终结果为min(dp[root][0],dp[root][1]).。

#include<iostream>
#include<cstring>
#include<vector>
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
const int maxn=1505;
int dp[maxn][2];
vector<int> G[maxn]; 

void dfs(int v,int root)
{
	for(int i=0;i<G[v].size();i++)
	{
		int u=G[v][i];
		if(u==root) continue;
		dfs(u,v);
		dp[v][0]+=dp[u][1];//不布置士兵 
		dp[v][1]+=min(dp[u][0],dp[u][1]);//布置士兵 
	}
}
int main()
{
	int n;
	while(cin>>n)
	{
		//初始化 
		mem(dp,0);
		for(int i=0;i<n;i++)
			G[i].clear();
		
		for(int i=0;i<n;i++)
		{
			int v,num;
			scanf("%d:(%d)",&v,&num);
			dp[v][1]=1;
			for(int j=0;j<num;j++)
			{
				int u;
				scanf("%d",&u);
				G[v].push_back(u);
				G[u].push_back(v);
			}
		}
		dfs(0,-1);
		cout<<min(dp[0][0],dp[0][1])<<endl;
		
	}
	return 0;
}

 

 

 

 

 

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章