POJ3624 Charm Bracelet(01揹包~~簡單DP~~)

Charm Bracelet
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 27287   Accepted: 12283

Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

第一天開始看動態規劃DP,先從揹包問題開始,找了揹包九講一點一點往下看,發現以前覺得怎麼都繞不過來的DP,只要弄清楚轉移方程,也並沒有想象中那麼難嘛 (*^-^*) 今天一共敲了四道簡單的揹包題,就因爲忘了把freopen註釋掉,wa了好幾次。。。。。。代碼習慣經常被隊友吐槽,正在慢慢改╮(╯▽╰)╭

POJ3624就是一個簡單的01揹包~~

/*01揹包*/
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>

using namespace std;

int w[4000],d[4000],dp[13000];

int main()
{
    //freopen("in.txt","r",stdin);
    int n,m;
    while(scanf("%d%d",&n,&m) != EOF)
    {
        memset(dp,0,sizeof(dp));
        for(int i = 0; i < n; i++)
        {
            scanf("%d%d", &w[i], &d[i]);
            for(int j = m; j >= 0; j--)//01揹包,從m到0循環;完全揹包反之。
                if(j>=w[i])
                    dp[j]=max(dp[j],dp[j-w[i]]+d[i]);
        }
        printf("%d\n",dp[m]);
    }
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章