次小生成树--Qin Shi Huang's National Road System

Qin Shi Huang's National Road System

 

During the Warring States Period of ancient China(476 BC to 221 BC), there were seven kingdoms in China ---- they were Qi, Chu, Yan, Han, Zhao, Wei and Qin. Ying Zheng was the king of the kingdom Qin. Through 9 years of wars, he finally conquered all six other kingdoms and became the first emperor of a unified China in 221 BC. That was Qin dynasty ---- the first imperial dynasty of China(not to be confused with the Qing Dynasty, the last dynasty of China). So Ying Zheng named himself "Qin Shi Huang" because "Shi Huang" means "the first emperor" in Chinese. 


Qin Shi Huang undertook gigantic projects, including the first version of the Great Wall of China, the now famous city-sized mausoleum guarded by a life-sized Terracotta Army, and a massive national road system. There is a story about the road system: 
There were n cities in China and Qin Shi Huang wanted them all be connected by n-1 roads, in order that he could go to every city from the capital city Xianyang. 
Although Qin Shi Huang was a tyrant, he wanted the total length of all roads to be minimum,so that the road system may not cost too many people's life. A daoshi (some kind of monk) named Xu Fu told Qin Shi Huang that he could build a road by magic and that magic road would cost no money and no labor. But Xu Fu could only build ONE magic road for Qin Shi Huang. So Qin Shi Huang had to decide where to build the magic road. Qin Shi Huang wanted the total length of all none magic roads to be as small as possible, but Xu Fu wanted the magic road to benefit as many people as possible ---- So Qin Shi Huang decided that the value of A/B (the ratio of A to B) must be the maximum, which A is the total population of the two cites connected by the magic road, and B is the total length of none magic roads. 
Would you help Qin Shi Huang? 
A city can be considered as a point, and a road can be considered as a line segment connecting two points.

Input

The first line contains an integer t meaning that there are t test cases(t <= 10). 
For each test case: 
The first line is an integer n meaning that there are n cities(2 < n <= 1000). 
Then n lines follow. Each line contains three integers X, Y and P ( 0 <= X, Y <= 1000, 0 < P < 100000). (X, Y) is the coordinate of a city and P is the population of that city. 
It is guaranteed that each city has a distinct location.

Output

For each test case, print a line indicating the above mentioned maximum ratio A/B. The result should be rounded to 2 digits after decimal point.

Sample Input

2
4
1 1 20
1 2 30
200 2 80
200 1 100
3
1 1 20
1 2 30
2 2 40

Sample Output

65.00
70.00

 题意描述:
秦始皇想要修路使得n个城市连通,同时使得这些路尽量短。这时徐福说他可以在2个城市之间不花费人力物力建一条路,但他只能建1条这样的路。秦始皇想要使除了徐福造的那条路以外的路的总长度尽量短,而徐福想要造福更多的百姓,他想要使自己用法术建的那条路的两端的城市的总人口数最多。最终二人达成协议。假设A=用法术建的那条路的两端的城市的总人口数,B=除了徐福造的那条路以外的路的总长度,建造的路要使得A/B最大。输出A/B。

解题思路:(转Noooooorth大佬)
我们可以先建一棵最小生成树,然后再从这n个城市中选择2个城市,把二者之间的路看做用法术造的路。如果这条路在最小生成树上,即去掉这条边后最小生成树会变成两棵独立的树,那么A/B就是(二者城市的人口数总和/最小生成树的值减去二者之间的长度);如果这条路不在生成树上,那么为了使A/B最大,我们要在最小生成树上删除一条权值最大的边使得生成树分为两棵树,同时这2个城市不在同一颗树上,然后就可以把这两个城市之间的路视为用法术造出的路,A/B就是
(二者城市的人口数总和/最小生成树的值减去二者之间某条使二者连通的边的最大长度)。
综上:我们可以使用used[i][j]表示i与j之间的边是否在最小生成树上,dp[i][j]表示i到j之间的使得i与j连通的权值最大的边的权值。在prim内更新dp数组。

AC代码: 

#include<algorithm>
#include<math.h>
#include<stdio.h>
#include<string.h>

using namespace std;

const double eps=1e-6;
const int INF=0x3f3f3f3f;
const int MAXN=1e3+20;

struct city
{
    int x,y,p;
}c[MAXN];

int V,par[MAXN];//par数组记录生成树上i的上一个点
bool used[MAXN][MAXN],visit[MAXN];
//used[i][j]表示i与j之间的边是否在最小生成树上
//visit数组用于标记一个点是否已经加入生成树 
double dis[MAXN],cost[MAXN][MAXN],dp[MAXN][MAXN];
//dp[i][j]表示i到j之间的使得i与j连通的权值最大的边的权值
//cost数组存放每条路的花费
//dis数组存放最小生成树的花费 
 
double prim(){
	//初始化 
    memset(visit,false,sizeof(visit));
    memset(dp,0,sizeof(dp));
    memset(used,false,sizeof(used));
    
    for(int i=1; i<=V; i++){//初始化
        dis[i]=cost[1][i];//dis数组,因为当前生成树只有1号顶点故为1号顶点到各顶点的距离
        par[i]=1;//没有上一个,所以就是自己 
    }
    visit[1]=true;//将一号顶点加入生成树 
    double res=0;//记录总共花费 
    
    for(int i=1; i<V; i++){
        int v=-1;
        for(int j=1; j<=V; j++)
            if(visit[j]==0&&(v==-1||dis[j]<dis[v]))
                v=j;//找到最小的距离 
        if(v==-1)	//所有点都在最小生成树中 
			break;
        visit[v]=true;//将找到的最小距离的点加入生成树中 
        used[v][par[v]]=used[par[v]][v]=true;//标记该边已在生成树种 
        res+=dis[v];
        
        for(int j=1;j<=V;j++){
            if(visit[j]==0&&cost[v][j]<dis[j]){
            	/*
            	*	当发现原来的dis[j]的距离比现在新加入的点到j点的距离更短时
		*	就将par[j]改为该点,那么下次搜寻最小点的时候就搜这条,而
		*	不是原来的那条,如上所示"used[v][par[v]]=used[par[v]][v]=true" 
            	*/
                dis[j]=cost[v][j];//从点v更新到各边的长度 
                par[j]=v;//v为上一个点 
            }
            if(visit[j]&&j!=v){//找出v与j连通的权值最大的边的权值
                dp[v][j]=dp[j][v]=max(dp[j][par[v]],dis[v]);
            }
        }
        
    }
    return res;//返回的结果是最小生成树的结果 
}
 
int main()
{
    int tcase;
    scanf("%d",&tcase);
    while(tcase--){
        //输入
        scanf("%d",&V);//V个城市
        for(int i=1; i<=V; i++)
        	scanf("%d%d%d",&c[i].x,&c[i].y,&c[i].p);
        //数据加工 
        for(int i=1; i<=V; i++)//计算两个城市的距离,用cost数组存放 
            for(int j=1; j<=V; j++)
                cost[i][j]=cost[j][i]=sqrt((c[i].x-c[j].x)*(c[i].x-c[j].x)+(c[i].y-c[j].y)*(c[i].y-c[j].y));
        //核心代码 
		double mst=prim();
        double ans=-1;//最终答案 
        for(int i=1; i<=V; i++){
            for(int j=1; j<=V; j++){
                if(i==j) 
                    continue;
                if(used[i][j])//i和j之间的边是否在最小生成树上
                /*
                *	如果这条路在最小生成树上,即去掉这条边后最小生成树会
		*	变成两棵独立的树,那么A/B就是
		*	二者城市的人口数总和/最小生成树的值减去二者之间的长度
                */	
                    ans=max(ans,(c[i].p+c[j].p+0.0)/(mst-cost[i][j])); 
                else
                /*
                *	如果这条路不在生成树上,那么为了使A/B最大,我们要
		*	在最小生成树上删除一条权值最大的边使得生成树分为两
		*	棵树,同时这2个城市不在同一颗树上,然后就可以把这
		*	两个城市之间的路视为用法术造出的路,A/B就是
		*	二者城市的人口数总和/最小生成树的值减去二者之间某条使二者连通的边的最大长度
                */
                    ans=max(ans,(c[i].p+c[j].p+0.0)/(mst-dp[i][j]));
            }
        }
        printf("%.2lf\n",ans);//答案保留两位小数 
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章