uva 674 - Coin Change


  Coin Change 

Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.


For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, two 5-cent coins and one 1-cent coin, one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.


Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 7489 cents.

Input 

The input file contains any number of lines, each one consisting of a number for the amount of money in cents.

Output 

For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.

Sample Input 

11
26

Sample Output 

4
1
#include<stdio.h>
#include<string.h>
#define max 7489
int a[max+1][5],b[5]={5,10,25,50};
int main()
{
 int i,j,x;
 for (i=1;i<=max;i++)
 a[i][0]=1;
 for (i=0;i<4;i++)
 {
  for (j=1;j<=max;j++)
  if (j<b[i]) a[j][i+1]=a[j][i];
         else if (j==b[i]) a[j][i+1]=a[j][i]+1;
                else       a[j][i+1]=a[j-b[i]][i+1]+a[j][i];
 }
 while (scanf("%d",&x)!=EOF)
 printf("%d\n",a[x][4]);
 return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章