Monkey and Banana dp

A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.
InputThe input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
OutputFor each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".
Sample Input
1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0
Sample Output
Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

題意:給定n種立方體,要求擺成塔狀(上面的長寬都小於下面的),求最大高度。
每個立方體我們都可以用不同的方向做高,所以可以當三個來用(長大於寬)
我們再根據只能小的放在大的上面,進行排序,排完後,我們依次去放就行,只要滿足,取最高的情況

#include<iostream>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
struct f{
	int l,w,h;
}a[110];
int dp[110];
bool cmp(f a,f b ){
	if(a.l>b.l)
	   return 1;
	if(a.l==b.l&&a.w>b.w)
	   return 1;
	return 0;
}
int main() {
	std::ios::sync_with_stdio(false);
	int n,Case=1;
	while(cin>>n) {
		if(n==0)
	    	break;
	    int d[3],m=0,Max=0;
		for(int i=0;i<n;i++){
			dp[i]=0;
			cin>>d[0]>>d[1]>>d[2];
			sort(d,d+3);
			a[m].h=d[0];a[m].l=d[2];a[m].w=d[1];m++;
			a[m].h=d[1];a[m].l=d[2];a[m].w=d[0];m++;
			a[m].h=d[2];a[m].l=d[1];a[m].w=d[0];m++;
		}
		sort(a,a+m,cmp);
		for(int i=0;i<m;i++)
		   dp[i]=a[i].h;
        for(int i=1;i<m;i++){
        	for(int j=0;j<i;j++){
        		if(a[i].l<a[j].l&&a[i].w<a[j].w)
        		   dp[i]=max(dp[i],dp[j]+a[i].h);
			}
			Max=max(Max,dp[i]);
		}
	  cout<<"Case "<<Case++<<": maximum height = "<<Max<<endl;
	}
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章