FatMouse and Cheese 【dp思想的dfs】

                            emmmmm 递归的dp? 就是在搜索的时候像dp一样找到最优子状态并储存。

题目:

FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move.

InputThere are several test cases. Each test case consists of

a line containing two integers between 1 and 100: n and k
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on.
The input ends with a pair of -1's.
OutputFor each test case output in a line the single integer giving the number of blocks of cheese collected.
Sample Input
3 1
1 2 5
10 11 6
12 12 7
-1 -1
Sample Output
37

题意:应该很好理解。。。就懒得翻译了
思路:
我们要找到由1,1走出来的最大解。那我们就以dp[1][1]为最终状态,而得到这个状态就要知道它能到达位置的最大解。用递归的思想求解。dp[i][j]就是从i,j出发达到的最大解。代码很容易看懂                                                                                                             第一次做,还是思想有堵塞。

#include<iostream>
#include<algorithm>
#include<cstring>
#include<queue>
#define ll long long
#define ld long double
#define INF 0x3f3f3f3f
using namespace std;
int map[102][102],dp[102][102];
int n,k;
int dfs(int x,int y){
	if(dp[x][y]>0)
	  return dp[x][y];
	int Max=0;
	for(int i=1;i<=k;i++){
		if((x+i)<=n&&map[x][y]<map[x+i][y])       //向下 
		    Max=max(Max,dfs(x+i,y));
		if((x-i)>0&&map[x][y]<map[x-i][y])        //向上 
		    Max=max(Max,dfs(x-i,y));
		if((y+i)<=n&&map[x][y]<map[x][y+i])       //向右 
		    Max=max(Max,dfs(x,y+i));
		if((y-i)>0&&map[x][y]<map[x][y-i])        //向左 
		    Max=max(Max,dfs(x,y-i));
	}
	dp[x][y]=Max+map[x][y];
	return  dp[x][y];
}
int main(){
	std::ios::sync_with_stdio(false);

	while(cin>>n>>k&&n!=-1){
		for(int i=1;i<=n;i++)
		  for(int j=1;j<=n;j++)
		     cin>>map[i][j];
	    memset(dp,0,sizeof dp);
		cout<<dfs(1,1)<<'\n';
	}
	
	return 0;
} 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章