HDU1078 FatMouse and Cheese

FatMouse and Cheese

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5816    Accepted Submission(s): 2373


Problem Description
FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move. 
 

Input
There are several test cases. Each test case consists of 

a line containing two integers between 1 and 100: n and k 
n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on. 
The input ends with a pair of -1's. 
 

Output
For each test case output in a line the single integer giving the number of blocks of cheese collected. 
 

Sample Input
3 1 1 2 5 10 11 6 12 12 7 -1 -1
 

Sample Output
37
 


解題思路:記憶化搜索+dp,不用多說

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#define inf 0x3f3f3f3f
using namespace std;
const int maxn = 105;
int mp[maxn][maxn], dp[maxn][maxn], n, k;
int dx[] ={1,-1,0,0},dy[] = {0,0,-1,1};

bool isok(int x,int y)
{
    if(x >= 0 && x < n && y >= 0 && y < n)
        return 1;
    return 0;
}

int dfs(int x,int y)
{
    if(dp[x][y])
        return dp[x][y];
    int res = 0;
    for(int i = 0;i < 4;++i)
    {
        for(int j = 1;j <= k;++j)
        {
            int tx = x+j*dx[i], ty = y+j*dy[i];
            if(isok(tx,ty) && mp[tx][ty] > mp[x][y])
            {
                res = max(res,dfs(tx,ty));
            }
        }
    }
    dp[x][y] = res + mp[x][y];

    return dp[x][y];
}
int main()
{
    while(~scanf("%d%d",&n,&k))
    {
        if(n == -1 && k == -1)
            break;
        for(int i = 0;i < n;++i)
            for(int j = 0;j < n;j++)
                scanf("%d",&mp[i][j]);
        memset(dp,0,sizeof(dp));
        dfs(0,0);
        cout<<dp[0][0]<<endl;
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章