hdu 2824 The Euler function

The Euler function

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4523    Accepted Submission(s): 1882


Problem Description
The Euler function phi is an important kind of function in number theory, (n) represents the amount of the numbers which are smaller than n and coprime to n, and this function has a lot of beautiful characteristics. Here comes a very easy question: suppose you are given a, b, try to calculate (a)+ (a+1)+....+ (b)
 

Input
There are several test cases. Each line has two integers a, b (2<a<b<3000000).
 

Output
Output the result of (a)+ (a+1)+....+ (b)
 

Sample Input
3 100
 

Sample Output
3042

 源代碼

<span style="font-size:18px;">#include<cstdio>
#define MAX 3000010
int a,b;
long long p[MAX];//long long型才能過MAX太大 

void euler()
{
	for(int i=2;i<=MAX;i++)
	{
		if(!p[i])
		{
			for(int j=i;j<=MAX;j+=i)
			{
				if(!p[j])
				p[j]=j;
				p[j]=p[j]/i*(i-1);
			}
		}
		p[i]+=p[i-1];
	}
}

int main()
{	
	euler();
	while(~scanf("%d%d",&a,&b))
	{
		printf("%lld\n",p[b]-p[a-1]);
	}
	return 0;
}</span>


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章