hdu3336Count the string

Count the string

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4646    Accepted Submission(s): 2184


Problem Description
It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:
s: "abab"
The prefixes are: "a", "ab", "aba", "abab"
For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab", it is 2 + 2 + 1 + 1 = 6.
The answer may be very large, so output the answer mod 10007.
 

Input
The first line is a single integer T, indicating the number of test cases.
For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.
 

Output
For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.
 

Sample Input
1 4 abab
 

Sample Output
6
 

Author
foreverlin@HNU
 
題意:
  1. 給以字符串 計算出以前i個字符爲前綴的字符中 在主串中出現的次數和  
  2.   
  3.              如: num(abab)=num(a)+num(ab)+num(aba)+num(abab)=2+2+1+1=6;  
代碼:
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int next[200005];
char str[200005];
void get_next(char *str,int n)
{
    int i,j;
    next[0]=-1;
    i=0;j=-1;
    while(i<n)
    {
        if(j==-1||str[i]==str[j])
            i++,j++,next[i]=j;
        else
            j=next[j];
    }
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        scanf("%s",str);
        get_next(str,n);
        int i,s=0;
        for(i=1;i<=n;i++)
        {
            if(next[i]!=0)  //next[i]表示前綴等於後綴的最大長度,需仔細理解kmp算法
                s++;
            if(s>10007)
                s=s%10007;
        }
        s=s+n;
        s=s%10007;
        printf("%d\n",s);
    }
    return 0;
}

第2種:
#include <stdio.h>  
#include <string.h>  
#include <iostream>  
using namespace std;  
#define MAXN 200005  
#define MOD 10007    
int next[MAXN],sum[MAXN],n;  
char str[MAXN];  
void getnext()  
{  
    int i = 0,j = -1;  
    next[0] = -1;  
    for(;str[i];)  
        if(j == -1 || str[i] == str[j])  
        {  
            ++i;  
            ++j;  
            next[i] = j;  
        }  
        else  
            j = next[j];  
} 
int main()  
{  
    int t,ans;  
    cin >> t;  
    while(t--)  
    {  
        getchar();  
        cin >> n;  
        ans = 0;  
        memset(sum,0,sizeof(sum));  
        scanf("%s",str);  
        getnext();  
        for(int i = 1; i<=n; i++)  
            sum[next[i]] = (sum[next[i]]+1)%MOD;  
        for(int i = 1; i<=n; i++)  
        {  
            if(sum[i])  
                ans=(ans+sum[i]+1)%MOD;  
            else  
                ans = (ans+1)%MOD;  
        }  
        cout << ans << endl;  
    }  
  
    return 0;  
}  


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章