1122 Hamiltonian Cycle(25 分)(cj)

1122 Hamiltonian Cycle(25 分)

The "Hamilton cycle problem" is to find a simple cycle that contains every vertex in a graph. Such a cycle is called a "Hamiltonian cycle".

In this problem, you are supposed to tell if a given cycle is a Hamiltonian cycle.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of vertices, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format Vertex1 Vertex2, where the vertices are numbered from 1 to N. The next line gives a positive integer K which is the number of queries, followed by K lines of queries, each in the format:

n V​1​​ V​2​​ ... V​n​​

where n is the number of vertices in the list, and V​i​​'s are the vertices on a path.

Output Specification:

For each query, print in a line YES if the path does form a Hamiltonian cycle, or NO if not.

Sample Input:

6 10
6 2
3 4
1 5
2 5
3 1
4 1
1 6
6 3
1 2
4 5
6
7 5 1 4 3 6 2 5
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 3 4 5 2 6
7 6 1 2 5 4 3 1

Sample Output:

YES
NO
NO
NO
YES
NO

code

#pragma warning(disable:4996)
#include <iostream>
#include <vector>
#include <set>
#include <algorithm>
using namespace std;
int map[205][205];
void init();
bool bol(vector<int>& v);
int n, m;
int main() {
	cin >> n >> m;
	int x, y;
	for (int i = 0; i < m; ++i) {
		cin >> x >> y;
		map[x][y] = 1;
		map[y][x] = 1;
	}
	int k, num;
	cin >> k;
	vector<int> varr;
	for (int i = 0; i < k; ++i) {
		varr.clear();
		cin >> num;
		for (int i = 0; i < num; ++i) {
			cin >> x;
			varr.push_back(x);
		}
		if (bol(varr)) {
			cout << "YES" << endl;
		}
		else cout << "NO" << endl;
	}
	system("pause");
	return 0;
}
void init() {
	for (int i = 0; i < 205; ++i) {
		map[i][i] = 1;
	}
}
bool bol(vector<int>& v) {
	if (v[0] != v[v.size() - 1]) return 0;
	set<int> ss;
	for (int i = 1; i < v.size(); ++i) {
		if (map[v[i - 1]][v[i]] == 0) return 0;
	}
	for (int i = 0; i < v.size() - 1; ++i) {
		if (ss.find(v[i]) != ss.end()) return 0;
		ss.insert(v[i]);
	}
	if (ss.size() != n) return 0;
	return 1;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章