1129 Recommendation System (25 分)(cj)

1129 Recommendation System (25 分)

Recommendation system predicts the preference that a user would give to an item. Now you are asked to program a very simple recommendation system that rates the user's preference by the number of times that an item has been accessed by this user.

Input Specification:

Each input file contains one test case. For each test case, the first line contains two positive integers: N (≤ 50,000), the total number of queries, and K (≤ 10), the maximum number of recommendations the system must show to the user. Then given in the second line are the indices of items that the user is accessing -- for the sake of simplicity, all the items are indexed from 1 to N. All the numbers in a line are separated by a space.

Output Specification:

For each case, process the queries one by one. Output the recommendations for each query in a line in the format:

query: rec[1] rec[2] ... rec[K]

where query is the item that the user is accessing, and rec[i] (i=1, ... K) is the i-th item that the system recommends to the user. The first K items that have been accessed most frequently are supposed to be recommended in non-increasing order of their frequencies. If there is a tie, the items will be ordered by their indices in increasing order.

Note: there is no output for the first item since it is impossible to give any recommendation at the time. It is guaranteed to have the output for at least one query.

Sample Input:

12 3
3 5 7 5 5 3 2 1 8 3 8 12

Sample Output:

5: 3
7: 3 5
5: 3 5 7
5: 5 3 7
3: 5 3 7
2: 5 3 7
1: 5 3 2
8: 5 3 1
3: 5 3 1
8: 3 5 1
12: 3 5 8

我用的是插入一個數後進行排序,不用把所有數排序,排k個就可以了。 

code

 

#pragma warning(disable:4996)
#include <iostream>
#include <vector>
#include <queue>
#include <algorithm>
using namespace std;
int recnum[50005];
vector<int> vin,vres;
bool cmp(const int& a, const int& b);
int main() {
	int n, k, x;
	cin >> n >> k;
	for (int i = 0; i < n; ++i) {
		cin >> x;
		vin.push_back(x);
	}
	for (int i = 0; i < n; ++i) {
		if (i != 0) {
			cout << vin[i] << ':';
			for (int i = 0; i < vres.size(); ++i) {
				cout << ' ' << vres[i];
			}
			cout << endl;
		}
		recnum[vin[i]]++;
		int p = vin[i];
		if (find(vres.begin(), vres.end(), p) == vres.end()) {
			if (vres.size() < k) vres.push_back(p);
			else {
				if (cmp(p, vres[k-1])) vres[k - 1] = p;
			}
		}
		sort(vres.begin(), vres.end(), cmp);
	}
	system("pause");
	return 0;
}
bool cmp(const int& a, const int& b) {
	if (recnum[a] == recnum[b]) return a < b;
	return recnum[a] > recnum[b];
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章