1133 Splitting A Linked List (25 分)(cj)

1133 Splitting A Linked List (25 分)

Given a singly linked list, you are supposed to rearrange its elements so that all the negative values appear before all of the non-negatives, and all the values in [0, K] appear before all those greater than K. The order of the elements inside each class must not be changed. For example, given the list being 18→7→-4→0→5→-6→10→11→-2 and K being 10, you must output -4→-6→-2→7→0→5→10→18→11.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10​5​​) which is the total number of nodes, and a positive K (≤10​3​​). The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer in [−10​5​​,10​5​​], and Next is the position of the next node. It is guaranteed that the list is not empty.

Output Specification:

For each case, output in order (from beginning to the end of the list) the resulting linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 9 10
23333 10 27777
00000 0 99999
00100 18 12309
68237 -6 23333
33218 -4 00000
48652 -2 -1
99999 5 68237
27777 11 48652
12309 7 33218

Sample Output:

33218 -4 68237
68237 -6 48652
48652 -2 12309
12309 7 00000
00000 0 99999
99999 5 23333
23333 10 00100
00100 18 27777
27777 11 -1

code

#pragma warning(disable:4996)
#include <iostream>
#include <vector>
#include <stdio.h>
#include <string>
using namespace std;
int address[100000][2];
vector<pair<int,int>> va;
int main() {
	int head, n, k;
		cin >> head >> n >> k;
	int add, val, next;
	for (int i = 0; i < n; ++i) {
		cin >> add >> val >> next;
		address[add][0] = val;
		address[add][1] = next;
	}
	int p = head;
	while (p != -1) {
		if (address[p][0] < 0) va.push_back(make_pair(p, address[p][0]));
		p = address[p][1];
	}
	p = head;
	while (p != -1) {
		if (address[p][0] >= 0 && address[p][0] <= k) va.push_back(make_pair(p, address[p][0]));
		p = address[p][1];
	}
	p = head;
	while (p != -1) {
		if (address[p][0] > k) va.push_back(make_pair(p, address[p][0]));
		p = address[p][1];
	}
	for (int i = 0; i < va.size() - 1; ++i) {
		printf("%05d %d %05d\n", va[i].first, va[i].second, va[i + 1].first);
	}
	printf("%05d %d -1\n", va[va.size() - 1].first, va[va.size() - 1].second);
	system("pause");
	return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章