1115 Counting Nodes in a BST(30 分)(cj)

1115 Counting Nodes in a BST(30 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than or equal to the node's key.
  • The right subtree of a node contains only nodes with keys greater than the node's key.
  • Both the left and right subtrees must also be binary search trees.

Insert a sequence of numbers into an initially empty binary search tree. Then you are supposed to count the total number of nodes in the lowest 2 levels of the resulting tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤1000) which is the size of the input sequence. Then given in the next line are the N integers in [−10001000] which are supposed to be inserted into an initially empty binary search tree.

Output Specification:

For each case, print in one line the numbers of nodes in the lowest 2 levels of the resulting tree in the format:

n1 + n2 = n

where n1 is the number of nodes in the lowest level, n2 is that of the level above, and n is the sum.

Sample Input:

9
25 30 42 16 20 20 35 -5 28

Sample Output:

2 + 4 = 6

令人懷念的指針二叉樹。。。 

code

#pragma warning(disable:4996)
#include <iostream>
#include <string>
#include <vector>
#include <cmath>
#include <set>
#include <stdio.h>
using namespace std;
class tree {
public:
	int val;
	tree *left = NULL, *right=NULL;
};
void insert(tree*& head, int x) {
	if (head == NULL) {
		head = new tree;
		head->val = x;
		return;
	}
	if (x > head->val) insert(head->right, x);
	else insert(head->left, x);
}
int levelnum[1000];
void runer(tree* head, int level) {
	if (head == NULL) return;
	levelnum[level]++;
	runer(head->left, level + 1);
	runer(head->right, level + 1);
}
int main() {
	int n, x;
	cin >> n;
	tree* p = NULL;
	for (int i = 0; i < n; ++i) {
		cin >> x;
		insert(p, x);
	}
	runer(p,1);
	for (int i = 99; i >= 0; --i) {
		if (levelnum[i] != 0) {
			cout << levelnum[i] << " + " << levelnum[i - 1] <<" = "<<levelnum[i]+levelnum[i-1] << endl;
			break;
		}
	}
	system("pause");
	return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章