1142 Maximal Clique (25 分)(cj)

1142 Maximal Clique (25 分)

clique is a subset of vertices of an undirected graph such that every two distinct vertices in the clique are adjacent. A maximal clique is a clique that cannot be extended by including one more adjacent vertex. (Quoted from https://en.wikipedia.org/wiki/Clique_(graph_theory))

Now it is your job to judge if a given subset of vertices can form a maximal clique.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers Nv (≤ 200), the number of vertices in the graph, and Ne, the number of undirected edges. Then Ne lines follow, each gives a pair of vertices of an edge. The vertices are numbered from 1 to Nv.

After the graph, there is another positive integer M (≤ 100). Then M lines of query follow, each first gives a positive number K (≤ Nv), then followed by a sequence of K distinct vertices. All the numbers in a line are separated by a space.

Output Specification:

For each of the M queries, print in a line Yes if the given subset of vertices can form a maximal clique; or if it is a clique but not a maximal clique, print Not Maximal; or if it is not a clique at all, print Not a Clique.

Sample Input:

8 10
5 6
7 8
6 4
3 6
4 5
2 3
8 2
2 7
5 3
3 4
6
4 5 4 3 6
3 2 8 7
2 2 3
1 1
3 4 3 6
3 3 2 1

Sample Output:

Yes
Yes
Yes
Yes
Not Maximal
Not a Clique

這題用集合的 交併差 做是最好的 但是STL中的 集合操作有點複雜,所以還是自己手寫一個 雖然效率會低一些 但是簡單!。

交操作

set<int> _intersection(set<int>& a, set<int>& b) {
	set<int> res;
	for (auto it = b.begin(); it != b.end(); ++it) {
		if (a.find(*it) != a.end()) res.insert(*it);
	}
	return res;
}

並操作

set<int> _union(set<int>& a, set<int>& b) {
	set<int> res = a;
	for (auto it = b.begin(); it != b.end(); ++it) {
		res.insert(*it);
	}
	return res;
}

是否爲子集

bool issubset(set<int>& a, set<int>& b) {
	if (a.size() > b.size()) return 0;
	for (auto it = a.begin(); it != a.end(); ++it) {
		if (b.find(*it) == b.end())	return 0;
	}
	return 1;
}

 

code

#pragma warning(disable:4996)
#include <iostream>
#include <set>
using namespace std;
set<int> vnode[205];
set<int> _union(set<int>& a, set<int>& b);
set<int> _intersection(set<int>& a, set<int>& b);
bool issubset(set<int>& a, set<int>& b);
int main() {
	int n, m;
	cin >> n >> m;
	for (int i = 1; i <= n; ++i) vnode[i].insert(i);
	int x, y;
	for (int i = 0; i < m; ++i) {
		cin >> x >> y;
		vnode[x].insert(y);
		vnode[y].insert(x);
	}
	int k;
	cin >> k;
	int num;
	set<int> tmp,vset;
	for (int i = 0; i < k; ++i) {
		tmp.clear();
		cin >> num;
		cin >> x;
		tmp.insert(x);
		vset = vnode[x];
		while (--num) {
			cin >> x;
			tmp.insert(x);
			vset =_intersection(vset, vnode[x]);
		}
		if (tmp == vset) cout << "Yes" << endl;
		else if (issubset(tmp, vset)) cout << "Not Maximal" << endl;
		else cout << "Not a Clique" << endl;
	}
	system("pause");
	return 0;
}
set<int> _union(set<int>& a, set<int>& b) {
	set<int> res = a;
	for (auto it = b.begin(); it != b.end(); ++it) {
		res.insert(*it);
	}
	return res;
}
set<int> _intersection(set<int>& a, set<int>& b) {
	set<int> res;
	for (auto it = b.begin(); it != b.end(); ++it) {
		if (a.find(*it) != a.end()) res.insert(*it);
	}
	return res;
}
bool issubset(set<int>& a, set<int>& b) {
	if (a.size() > b.size()) return 0;
	for (auto it = a.begin(); it != a.end(); ++it) {
		if (b.find(*it) == b.end())	return 0;
	}
	return 1;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章