1143 Lowest Common Ancestor (30 分)(cj)

1143 Lowest Common Ancestor (30 分)

The lowest common ancestor (LCA) of two nodes U and V in a tree is the deepest node that has both U and V as descendants.

A binary search tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

Given any two nodes in a BST, you are supposed to find their LCA.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 1,000), the number of pairs of nodes to be tested; and N (≤10,000), the number of keys in the BST, respectively. In the second line, N distinct integers are given as the preorder traversal sequence of the BST. Then M lines follow, each contains a pair of integer keys U and V. All the keys are in the range of int.

Output Specification:

For each given pair of U and V, print in a line LCA of U and V is A. if the LCA is found and A is the key. But if A is one of U and V, print X is an ancestor of Y.where X is A and Y is the other node. If U or V is not found in the BST, print in a line ERROR: U is not found. or ERROR: V is not found. or ERROR: U and V are not found..

Sample Input:

6 8
6 3 1 2 5 4 8 7
2 5
8 7
1 9
12 -3
0 8
99 99

Sample Output:

LCA of 2 and 5 is 3.
8 is an ancestor of 7.
ERROR: 9 is not found.
ERROR: 12 and -3 are not found.
ERROR: 0 is not found.
ERROR: 99 and 99 are not found.

題目 中 樹的key 會正會負 大小很大 這點建數組時注意

然後就是指針建二叉樹 然後 遍歷找根節點。

注意一點 1 1  輸出 應該是 1 is an ancestor of y    

code

#pragma warning(disable:4996)
#include <iostream>
#include <vector>
#include <stdio.h>
#define inf 0x7fffffff
using namespace std;
class tree {
public:
	int val;
	tree* left = NULL, *right = NULL;
};
vector<int> preorder;
int x, y, tmp;
void buildtree(int l,int r, tree*& p);
void pretravel(tree*& p);
int travel(tree* p);
int main() {
	int m, n;
	cin >> m >> n;
	for (int i = 0; i < n; ++i) {
		cin >> x;
		preorder.push_back(x);
	}
	tree* head = NULL;
	buildtree(0, n - 1, head);
	for (int i = 0; i < m; ++i) {
		cin >> x >> y;
		tmp = inf;
		int g = travel(head);
		if (g == 1) {
			if (tmp != inf) printf("%d is an ancestor of %d.\n", x, y);
			else printf("ERROR: %d is not found.\n", y);
		}
		else if (g == 2) {
			if (tmp != inf) printf("%d is an ancestor of %d.\n", y, x);
			else printf("ERROR: %d is not found.\n", x);
		}
		else if (g == 0) printf("ERROR: %d and %d are not found.\n", x, y);
		else printf("LCA of %d and %d is %d.\n", x, y, tmp);
	}
	system("pause");
	return 0;
}
int travel(tree* p) {
	if (p == NULL) return 0;
	if (p->val == x) {
		int g = travel(p->left);
		g += travel(p->right);
		if (p->val == y) g++;
		if (g != 0) tmp = y;
		return 1;
	}
	if (p->val == y) {
		int g = travel(p->left);
		g += travel(p->right);
		if (p->val == x) g++;
		if (g != 0) tmp = x;
		return 2;
	}
	int g = 0;
	g+=travel(p->left);
	if (g == 3) {
		if (tmp == inf) tmp = p->val;
		return g;
	}
	g+=travel(p->right);
	if (g == 3) {
		if (tmp == inf) tmp = p->val;
		return g;
	}
}
void pretravel(tree*& p) {
	if (p == NULL) return;
	cout << p->val << ' ';
	pretravel(p->left);
	pretravel(p->right);
}
void buildtree(int l, int r, tree*& p) {
	if (l > r) return;
	p = new tree;
	p->val = preorder[l];
	if (l == r) return;
	int pos;
	for (pos = l + 1; pos <= r; ++pos) {
		if (preorder[pos] >= preorder[l]) break;
	}
	buildtree(l + 1, pos - 1, p->left);
	buildtree(pos, r, p->right);
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章