HDU - 3555 Bomb(數位dp)

The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence “49”, the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.
Output
For each test case, output an integer indicating the final points of the power.
Sample Input
3
1
50
500
Sample Output
0
1
15

Hint
From 1 to 500, the numbers that include the sub-sequence “49” are “49”,“149”,“249”,“349”,“449”,“490”,“491”,“492”,“493”,“494”,“495”,“496”,“497”,“498”,“499”,
so the answer is 15.


題意:求0 到n的數中有多少個數字是含有‘49’的!

解題思路:用數位dp跑一下0到n的不含有‘49’的,然後n減去就行了,具體思路見代碼註釋。
dp[pos][sta]表示當前第pos位,前一位是否是4的狀態,這裏sta只需要去0和1兩種狀態就可以了,不是4的情況可視爲同種,不會影響計數。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
typedef long long ll;
ll dp[20][2];
//dp[pos][sta]表示當前第pos位,前一位是否是4的狀態,這裏sta只需要去0和1兩種狀態就可以了,不是4的情況可視爲同種,不會影響計數。
int a[20];
ll dfs(int pos,int pre,int sta,int limit){
    if(pos==-1)//所有數枚舉完了,當前數數字肯定滿足條件,直接返回1
        return 1;
    if(!limit && dp[pos][sta]!=-1)//記憶化
        return dp[pos][sta];
    int up=limit?a[pos]:9;
    ll tmp=0;
    for(int i=0;i<=up;i++){
        if(pre==4&&i==9)//pre是該數字的前一位,出現49就直接跳過。
            continue;//保證枚舉正確性
        tmp+=dfs(pos-1,i,i==4,limit&&i==a[pos]);//
    }
    if(!limit)
        dp[pos][sta]=tmp;
    return tmp;
}
ll solve(ll t)
{
    int len=0;
    ll n=t;
    while(n)
    {
        a[len++]=n%10;
        n/=10;
    }
    return t+1-dfs(len-1,-1,0,1);
}
int main()
{
    int T;
    ll n;
    memset(dp,-1,sizeof dp);//放在外面會優化一點時間
    scanf("%d",&T);
    while(T--){
        scanf("%lld",&n);
        printf("%lld\n",solve(n));
    }
    return 0;
}

發佈了43 篇原創文章 · 獲贊 26 · 訪問量 3998
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章