POJ 2785 4 Values whose sum is 0

4 Values whose Sum is 0

Time Limit: 15000MS Memory Limit: 228000K
Total Submissions: 24017 Accepted: 7283
Case Time Limit: 5000MS

Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 228 ) that belong respectively to A, B, C and D .

Output

For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

Sample Output

5

Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).

Thinking:如果四個數組遍歷就會是O(n^4)的時間複雜度,如果c+d = -a-b, 複雜度就會降到O(n^2). 同時使用upper_bound 和 lower_bound 函數。

#include<cstdio>
#include<algorithm>
using namespace std;

const int maxn = 4000+3;
int A[maxn], B[maxn], C[maxn], D[maxn];
int CD[maxn*maxn];
int N;

void solve(){
    for(int i = 0; i < N; i++)
        for(int j = 0; j < N; j++)
            CD[i*N+j] = C[i] + D[j];
    sort(CD, CD+N*N);

    long long res = 0;
    for(int i = 0; i < N; i++){
        for(int j = 0; j < N; j++){
            int cd = -A[i]-B[j];
            res += upper_bound(CD, CD+N*N, cd) - lower_bound(CD, CD+N*N, cd);
        }
    }

    printf("%lld\n", res);
}

int main(){
    scanf("%d", &N);
    for(int i = 0; i < 6; i++){
        scanf("%d%d%d%d", &A[i], &B[i], &C[i], &D[i]);
    }
    solve();
    return 0;
}
發佈了38 篇原創文章 · 獲贊 11 · 訪問量 1萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章