POJ 2385 Apple Catching

Apple Catching

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13283 Accepted: 6462

Description

It is a little known fact that cows love apples. Farmer John has two apple trees (which are conveniently numbered 1 and 2) in his field, each full of apples. Bessie cannot reach the apples when they are on the tree, so she must wait for them to fall. However, she must catch them in the air since the apples bruise when they hit the ground (and no one wants to eat bruised apples). Bessie is a quick eater, so an apple she does catch is eaten in just a few seconds.

Each minute, one of the two apple trees drops an apple. Bessie, having much practice, can catch an apple if she is standing under a tree from which one falls. While Bessie can walk between the two trees quickly (in much less than a minute), she can stand under only one tree at any time. Moreover, cows do not get a lot of exercise, so she is not willing to walk back and forth between the trees endlessly (and thus misses some apples).

Apples fall (one each minute) for T (1 <= T <= 1,000) minutes. Bessie is willing to walk back and forth at most W (1 <= W <= 30) times. Given which tree will drop an apple each minute, determine the maximum number of apples which Bessie can catch. Bessie starts at tree 1.

Input

  • Line 1: Two space separated integers: T and W

  • Lines 2..T+1: 1 or 2: the tree that will drop an apple each minute.

Output

  • Line 1: The maximum number of apples Bessie can catch without walking more than W times.

Sample Input

7 2
2
1
1
2
2
1
1

Sample Output

6

#include<cstdio>
#include<algorithm>
using namespace std;

int N, W;
const int maxn = 1000+5;
const int maxm = 30+5;
int tree[maxn];
int dp[maxn][maxn];

void solve(){
        if(tree[1] == 1){ //第一次在樹一下站着, apple從第一棵樹上落下 
            dp[1][0] = 1; //不用移動,apple+1 
            dp[1][1] = 0; //移動,apple = 0 
        }
        else if(tree[1] == 2){ //蘋果從第二棵樹上落下 
            dp[1][0] = 0; //不移動 apple = 0 
            dp[1][1] = 1; //移動,apple+1 
        }

        for(int i = 2; i <= N; i++)
            for(int j = 0; j <= W; j++){
                if(j == 0 ){ //當時間爲i時,移動次數爲0, 此時還站在樹 1 的下面 
                    dp[i][j] = dp[i-1][j] + tree[i]%2; //如果apple從樹一上落下,那麼tree[i]%2 = 1, 可以接到蘋果。
                    continue;                           //如果從樹二上落下,tree[i]%2 = 0, 不可以接到蘋果 
                } 
                dp[i][j] = max(dp[i-1][j], dp[i-1][j-1]);//時間爲i的時候,移動j次時獲得的最多apple, 
                if(j%2+1 == tree[i])  //如果本次(由上得出的只是移動不移動的情況,並沒有判斷時間爲i時,apple從哪個樹上落下)
                                                //是站在第 i 棵樹下,就會多收穫一顆apple 
                    dp[i][j]++;
            }

        int res = 0;    
        for(int i = 0; i <= W; i++)
            res = max(res, dp[N][i]);
        printf("%d\n", res);
}

int main(){
    scanf("%d%d", &N, &W);
    for(int i = 1; i <= N; i++)
        scanf("%d", &tree[i]);
    solve();
    return 0;
}
發佈了38 篇原創文章 · 獲贊 11 · 訪問量 1萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章