POJ2533 Longest Ordered Subsequence【最長上升子序列+DP】

問題鏈接:POJ2533 Longest Ordered Subsequence

Description

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. Let the subsequence of the given numeric sequence (a1a2, ..., aN) be any sequence (ai1ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

Source

Northeastern Europe 2002, Far-Eastern Subregion

 

問題分析:這是一個最長上升子序列問題,使用DP算法實現。

  定義f[i]=以a[i]爲末尾的最長上升子序列的長度。

  那麼,以a[i]爲末尾的最長上升子序列有以下兩種情形:

  1.只包含a[i]的子序列

  2.滿足j<i並且a[j]<a[i]的以a[j]爲結尾的上升子序列末尾,追加上a[i]後得到的子序列,通過循環找到f[j]+1的最大值。

  即:f[i]=max{1,f[j]+1}

#include <iostream>
using namespace std;
///////////ac
int a[1005],f[1005];
int res(int n)
{
	int s=0;
	for(int i=0;i<n;i++)
	{
		f[i]=1;//爲f[i]設置初值,最初只包含a[i] 
		for(int j=0;j<i;j++)
		{
			if(a[j]<a[i])
			{
				f[i]=max(f[i],f[j]+1);
			}
		}
		s=max(s,f[i]);//記錄f[i]的最大值 
	}
	return s;
}
int main()
{
	int n;
	while(cin>>n)
	{
		for(int i=0;i<n;i++)
		{
			cin>>a[i];
		}
		cout<<res(n)<<endl;
	}
	return 0;
}

 

發佈了52 篇原創文章 · 獲贊 8 · 訪問量 7098
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章