HDU 1025 Constructing Roads In JGShining's Kingdom

Constructing Roads In JGShining's Kingdom

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 24050    Accepted Submission(s): 6871


Problem Description
JGShining's kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines.

Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource. You may assume no two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource.

With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they're unable to ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor cities don't wanna build a road with other poor ones, and rich ones also can't abide sharing an end of road with other rich ones. Because of economic benefit, any rich city will be willing to export resource to any poor one.

Rich citis marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II.

The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities ... And so as the poor ones.

But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads.

For example, the roads in Figure I are forbidden.



In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. ^_^
 

Input
Each test case will begin with a line containing an integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers p and r which represents that Poor City p needs to import resources from Rich City r. Process to the end of file.
 

Output
For each test case, output the result in the form of sample.
You should tell JGShining what's the maximal number of road(s) can be built.
 

Sample Input
2 1 2 2 1 3 1 2 2 3 3 1
 

Sample Output
Case 1: My king, at most 1 road can be built. Case 2: My king, at most 2 roads can be built.
Hint
Huge input, scanf is recommended.


一道动态规划问题,富裕的城市修路到贫穷的城市,且中间不能出现交叉点,即求最长递增子序列,代码如下:

#include<iostream>
#include<stdio.h>
using namespace std;
const int N=500005;
int b[N],a[N];  //d[N]用来存最长不降子序列
int BinarySearch(int key,int left,int right)
{
	int mid=0;
	while(left<=right)
	{
		 mid=(left+right)/2;
		if(b[mid]<=key)left=mid+1;
		else right=mid-1;
	}
	return left;
}

int dp(int n){
	int len,pos;
	b[1]=a[1];
	len=1;
	for(int i=2;i<=n;i++)
	{
		if(a[i]>=b[len])
		{
			b[++len]=a[i];
		}
		else {
			pos=BinarySearch(a[i],1,len);
			b[pos]=a[i];
		}
	}
	return len;
}

int main()
{
	int n;
	int i=1;
	while(cin>>n){   
		for(int i=0;i<n;i++)
		{
			int x,y;
		    //	cin>>x>>y;
		    scanf("%d%d",&x,&y);
			a[x]=y;
		}
		cout<<"Case "<<i++<<":"<<endl;
		int res=dp(n);
		if(res==1)
		cout<<"My king, at most "<<1<<" road can be built."<<endl<<endl;
		else cout<<"My king, at most "<<res<<" roads can be built."<<endl<<endl;
	}	
} 

这道题目有意思的就是在输入上面的 x还有y时,如果用C++语言的输入方式,则运行超时,而用C语言的输入则可以AC,因为C++的输入所花的时间比C语言所花的时间要多。
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章