hdu 1024 最大上升子序列

Max Sum Plus Plus

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 31477    Accepted Submission(s): 11131


Problem Description
Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S1, S2, S3, S4 ... Sx, ... Sn (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ Sx ≤ 32767). We define a function sum(i, j) = Si + ... + Sj (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i1, j1) + sum(i2, j2) + sum(i3, j3) + ... + sum(im, jm) maximal (ix ≤ iy ≤ jx or ix ≤ jy ≤ jx is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(ix, jx)(1 ≤ x ≤ m) instead. ^_^
 

Input
Each test case will begin with two integers m and n, followed by n integers S1, S2, S3 ... Sn.
Process to the end of file.
 

Output
Output the maximal summation described above in one line.
 

Sample Input
1 3 1 2 3 2 6 -1 4 -2 3 -2 3
 

Sample Output
6 8
Hint
Huge input, scanf and dynamic programming is recommended.

題意就是求一段序列中給定條數的子序列的最大總值
那麼就有在遍歷該序列的每一個數來選子序列時就有兩種方法:
1.把該數作爲單獨的一段
2.把該數與前一個數所在的子序列融合
所以,狀態轉移方程就是:
dp[i][j] = max(dp[i][j - 1], dp[i - 1][j - 1]) + str[j];
其中,i 表示段數,j 表示第 j 個數,str【】表示總序列


代碼:



#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <cmath>
#include <vector>
using namespace std;
typedef long long LL;
///o(っ。Д。)っ AC萬歲!!!!!!!!!!!!!!


const int maxn = 1700000, inf = -199999999;
LL str[maxn] = {}, dp[2][maxn] = {};


int main()
{
    int n, m;
    while(~scanf("%d %d", &m, &n))
    {
        for(int i = 1; i <= n; i++)
        {
            scanf("%lld", &str[i]);
            dp[1][i] = dp[0][i] = 0;
        }
        dp[1][0] = dp[0][0] = 0;
        LL maxx = inf;
        for(int i = 1; i <= m; i++)
        {
            maxx = inf;
            for(int j = i; j <= n; j++)
            {
                dp[1][j] = max(dp[1][j - 1], dp[0][j - 1]) + str[j];
                dp[0][j - 1] = maxx;
                maxx = max(maxx, dp[1][j]);
            }
        }
        printf("%lld\n", maxx);
    }
    return 0;
}
/*
3 5
1 -2 -3 0 -1
2 5
1 -2 -3 0 -1
*/




發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章