hdoj_1379_Minimum Inversion Number_線段樹求逆序數

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9578    Accepted Submission(s): 5899


Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

Output
For each case, output the minimum inversion number on a single line.
 

Sample Input
10 1 3 6 9 0 8 5 7 4 2
 

Sample Output
16
 
#include <iostream>
#include <cstring>
#include <cstdio>
#define N 5010
using namespace std;

int sum[N * 2];
int a[N];

void pushUp(int rt)
{
    sum[rt] = sum[rt * 2] + sum[rt * 2 + 1];
}

void build(int l, int r, int rt)
{
    sum[rt] = 0;
    if(l == r)
        return ;
    int mid = (l + r) / 2;
    build(l, mid, rt * 2);
    build(mid + 1, r, rt * 2 + 1);
}

void update(int p, int l, int r, int rt)
{
    if (l == r)
    {
        sum[rt]++;
        return ;
    }
    int mid = (l + r) / 2;
    if (p <= mid)
        update(p, l, mid, rt * 2);
    else 
        update(p, mid + 1, r, rt * 2 + 1);
    pushUp(rt);
}

int query(int L, int R, int l, int r, int rt)
{
    if (L <= l && r <= R)
        return sum[rt];
    int mid = (l + r) / 2;
    int ret = 0;
    if (L <= mid)
        ret += query(L, R, l, mid, rt * 2);
    if (R > mid)
        ret += query(L, R, mid + 1, r, rt * 2 + 1);
    return ret;
}

int main()
{
    int n;
    while (scanf("%d", &n) != EOF)
    {
        memset(a, 0, sizeof(a));
        memset(sum, 0, sizeof(sum));
        build(0, n - 1, 1);
        int s = 0;
        for (int i = 0; i < n; i++)
        {
            scanf("%d", &a[i]);
            s += query(a[i], n - 1, 0, n - 1, 1);
            update(a[i], 0, n - 1, 1);
        }
        int ret = s;
        for (int i = 0; i < n; i++)
        {
            s += n - a[i] - a[i] - 1;
            ret = min(ret, s);
        }
        printf("%d\n", ret);
    }

    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章