poj_A Chess Game2425

A Chess Game
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 3094   Accepted: 1266

Description

Let's design a new chess game. There are N positions to hold M chesses in this game. Multiple chesses can be located in the same position. The positions are constituted as a topological graph, i.e. there are directed edges connecting some positions, and no cycle exists. Two players you and I move chesses alternately. In each turn the player should move only one chess from the current position to one of its out-positions along an edge. The game does not end, until one of the players cannot move chess any more. If you cannot move any chess in your turn, you lose. Otherwise, if the misfortune falls on me... I will disturb the chesses and play it again. 

Do you want to challenge me? Just write your program to show your qualification!

Input

Input contains multiple test cases. Each test case starts with a number N (1 <= N <= 1000) in one line. Then the following N lines describe the out-positions of each position. Each line starts with an integer Xi that is the number of out-positions for the position i. Then Xi integers following specify the out-positions. Positions are indexed from 0 to N-1. Then multiple queries follow. Each query occupies only one line. The line starts with a number M (1 <= M <= 10), and then come M integers, which are the initial positions of chesses. A line with number 0 ends the test case.

Output

There is one line for each query, which contains a string "WIN" or "LOSE". "WIN" means that the player taking the first turn can win the game according to a clever strategy; otherwise "LOSE" should be printed.

Sample Input

4
2 1 2
0
1 3
0
1 0
2 0 2
0

4
1 1
1 2
0
0
2 0 1
2 1 1
3 0 1 3
0

Sample Output

WIN
WIN
WIN
LOSE
WIN

#include <istream>
#include <cstring>
#include <cstdio>
#define N 1010
using namespace std;

int g[N];
int n;
bool map[N][N];

int sg(int num)
{
    if(g[num] != -1)
        return g[num];
    int temp = 0;
    for (int i = 0; i < n; i++)
    {
        if (map[num][i])
        {
            if (sg(i) == temp)
                temp++;
        }
    }
    g[num] = temp;
    return temp;
}

int main()
{
    while (scanf("%d", &n) != EOF)
    {
        memset(g, -1, sizeof(g));
        memset(map, 0, sizeof(map));
        for (int i = 0; i < n; i++)
        {
            int m;
            scanf("%d", &m);
            int sum = 0;
            while (m--)
            {
                int a;
                scanf("%d", &a);
                map[i][a] = 1;
                sum ++;
            }
            if(sum == 0)
                g[i] = 0;
        }
        int m;
        while (scanf("%d", &m) != EOF && m)
        {
            int res = 0;
            while (m--)
            {
                int a;
                scanf("%d", &a);
                res = res ^ sg(a);
            }
            if(res == 0)
                printf("LOSE\n");
            else 
                printf("WIN\n");
        }
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章