hdoj_Billboard_2795

Billboard

Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9299    Accepted Submission(s): 4139


Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
 

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
 

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
 

Sample Input
3 5 5 2 4 3 3 3
 

Sample Output
1 2 1 3 -1
 
#include <iostream>
#include <cstring>
#include <cstdio>
#define N 200010
using namespace std;

//記錄最大的空格數
int mmax[N * 3];//h <= 10 ^ 9, 但n <= 200000,只用到表的前n行
int h, w, m;

void pushUp(int num)
{
    mmax[num] = max(mmax[num * 2], mmax[num * 2 + 1]);
}

void build(int l, int r, int num)
{
    mmax[num] = w;
    if (l == r)
        return ;
    int mid = (l + r) / 2;
    build(l, mid, num * 2);
    build(mid + 1, r, num * 2 + 1);
}

int query(int val, int l, int r, int num)
{
    if (l == r)
    {
        mmax[num] -= val;
        return l + 1;
    }
    int mid = (l + r) / 2;
    int res;
    if (mmax[num * 2] >= val)
        res = query(val, l, mid, num * 2);
    else 
        res = query(val, mid + 1, r, num * 2 + 1);
    pushUp(num);
    return res;
}

int main()
{
    while (scanf("%d%d%d", &h, &w, &m) != EOF)
    {
        memset(mmax, 0, sizeof(mmax));
        if (h > m)
            h = m;
        build(0, h - 1, 1);
        while (m--)
        {
            int num;
            scanf("%d", &num);
            if (mmax[1] < num)
                printf("-1\n");
            else 
                printf("%d\n", query(num, 0, h - 1, 1));
        }
    }
    return 0;
}




發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章