hdu 3074 Multiply game

Multiply game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1190    Accepted Submission(s): 394


Problem Description
Tired of playing computer games, alpc23 is planning to play a game on numbers. Because plus and subtraction is too easy for this gay, he wants to do some multiplication in a number sequence. After playing it a few times, he has found it is also too boring. So he plan to do a more challenge job: he wants to change several numbers in this sequence and also work out the multiplication of all the number in a subsequence of the whole sequence.
  To be a friend of this gay, you have been invented by him to play this interesting game with him. Of course, you need to work out the answers faster than him to get a free lunch, He he…

 

Input
The first line is the number of case T (T<=10).
  For each test case, the first line is the length of sequence n (n<=50000), the second line has n numbers, they are the initial n numbers of the sequence a1,a2, …,an, 
Then the third line is the number of operation q (q<=50000), from the fourth line to the q+3 line are the description of the q operations. They are the one of the two forms:
0 k1 k2; you need to work out the multiplication of the subsequence from k1 to k2, inclusive. (1<=k1<=k2<=n) 
1 k p; the kth number of the sequence has been change to p. (1<=k<=n)
You can assume that all the numbers before and after the replacement are no larger than 1 million.
 

Output
For each of the first operation, you need to output the answer of multiplication in each line, because the answer can be very large, so can only output the answer after mod 1000000007.
 

Sample Input
1 6 1 2 4 5 6 3 3 0 2 5 1 3 7 0 2 5
 

Sample Output
240 420
 

本題是單點更新,線段樹!

AC代碼

#include <iostream>
using namespace std;
#define lson l,m,rt*2
#define rson m+1,r,rt*2+1
#define maxn 50005
__int64 sum[maxn<<2];
void build(int l,int r,int rt)
{
	if(l==r)
	{
	  scanf("%I64d",&sum[rt]);
	  return;
	}
	int m=(r+l)/2;
	build(lson);
	build(rson);
	sum[rt]=(sum[rt*2]*sum[rt*2+1])%1000000007;
}
void update(int p,int x,int l,int r,int rt)
{
	if (l==r)
	{
		sum[rt]=x;
		return;
	}
	int m=(r+l)/2;
	if(p<=m)
		update(p,x,lson);
	else
		update(p,x,rson);
	sum[rt]=(sum[rt*2]*sum[rt*2+1])%1000000007;
}
__int64 query(int L,int R,int l,int r,int rt)
{
	if (l>=L&&r<=R)
		return sum[rt]%1000000007;
	int m=(r+l)/2;
	__int64 ret=1;
	if (L<=m)
	ret*=query(L,R,lson)%1000000007;
	if(R>m)
	ret*=query(L,R,rson)%1000000007;
	return ret%1000000007;
	
}
int main()
{
	int t,n,q,a,b,c;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		build(1,n,1);
		scanf("%d",&q);
		while(q--)
		{
			
			scanf("%d%d%d",&a,&b,&c);
		     	if(a==0)
				printf("%I64d\n",query(b,c,1,n,1));
			else
				if (a==1)
				update(b,c,1,n,1);
				
		}
	}
	return 0;
}

切記用64位,否則WA!

謝謝閱讀!

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章