課程練習二-1003-pie

Problem Description
My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.<br><br>My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size. <br><br>What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.<br>
 

Input
One line with a positive integer: the number of test cases. Then for each test case:<br>---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.<br>---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.<br>
 

Output
For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).
 

Sample Input
3<br>3 3<br>4 3 3<br>1 24<br>5<br>10 5<br>1 4 2 3 4 5 6 5 4 2<br>
 

Sample Output
25.1327<br>3.1416<br>50.2655<br>
 
題意:
有f+1個人分n塊披薩,每個人要求分得的面積一樣,且披薩只能被切開而不能重新組合,求每個人能分到的最大面積v。
注意:F個朋友+自己
思路:
每個人要得到一張完整的餅,而不能多個組合。對最大的餅(high)與0(low)進行二分,判斷mid是否sum(size[i])/mid是否大於等於F+1;

AC代碼:

#include<iostream>
#include<iomanip>
#include<stdlib.h>
#include<algorithm>
#include<math.h>
#include<string.h>
using namespace std;


bool judge(double mid,int n,int f,double size[])
{
int  p = 0;
for (int i = 0; i < n; ++i)
{
p += int(size[i] / mid);
}
return p >= f+1;
}


int main()
{
int n;
cin >> n;
while (n--)
{
int N, F;
double pi = acos(-1);
cin >> N >> F;
double size[10001];
memset(size, 0, sizeof(size));
int a = 0;
for (int i = 0; i < N; i++)
{
cin >> a;
size[i] = a*a*pi;  //把每個餅的面積存入數組,本來是將半徑存入數組最後進行pi*r*r的,結果總是通不過測試數據。
}
double high = size[0];
for (int i = 0; i < N; i++)
{
if (size[i]>high)
{
high = size[i];
}
}
double mid;
double low = 0;
double ans = 0;
//cout << high << endl;
while ((high - low) > 0.00001)
{
mid = (high + low) / 2;
//cout << judge(mid, N, F, size) << endl;
if (judge(mid, N, F, size))
{
low = mid;
ans = mid;
}
else {
high = mid;
}
}
//cout << ans << endl;
double jg = ans;
cout << setprecision(4) << fixed <<jg<< endl;
}
system("pause");
return 0;
}






發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章