課程練習二-1002

Problem Description
Now, here is a fuction:<br>&nbsp;&nbsp;F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 &lt;= x &lt;=100)<br>Can you find the minimum value when x is between 0 and 100.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
 

Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
 

Sample Input
2<br>100<br>200
 

Sample Output
-74.4291<br>-178.8534
 

Author
Redow
 
題意:輸入Y, 根據公式 F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-Y*x (0<=x<=100),求出   F(x)的最小值。


思路:先求導得到:f(x)=42*x^6+48*x^5+21*x^2+10*x-Y 。然後根據數學知識,判斷F(x)的增減性。

然後根據Problem A的做法就ok了。(二分查找法)


代碼:

#include<iostream>
#include<iomanip>
#include<cmath>
#include<stdlib.h>
using namespace std;
int main()
{
int T;
cin>>T;
for(int i=0;i<T;i++)
{
int Y;
cin>>Y;
double max=100;
double min=0;
if(42*pow(100,6)+48*pow(100,5)+21*pow(100,2)+10<Y)
cout<<setprecision(4)<<fixed<<100.0<<endl;
else if(0>Y)
{
cout<<setprecision(4)<<fixed<<0.0<<endl;
}
else{
while((max-min)>0.000001)
{
double x=(max+min)/2;
if(42*pow(x,6)+48*pow(x,5)+21*pow(x,2)+10*x>Y)
max=x;
else min=x;
if((max-min)<0.00001)
{
cout<<setprecision(4)<<fixed<<6*pow(x,7)+8*pow(x,6)+7*pow(x,3)+5*x*x-Y*x<<endl;
break;
}
}
 }
}

system("pause");
return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章