POJ 1287 Networking【最小生成樹】


Networking
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 11840   Accepted: 6398

Description

You are assigned to design network connections between certain points in a wide area. You are given a set of points in the area, and a set of possible routes for the cables that may connect pairs of points. For each possible route between two points, you are given the length of the cable that is needed to connect the points over that route. Note that there may exist many possible routes between two given points. It is assumed that the given possible routes connect (directly or indirectly) each two points in the area. 
Your task is to design the network for the area, so that there is a connection (direct or indirect) between every two points (i.e., all the points are interconnected, but not necessarily by a direct cable), and that the total length of the used cable is minimal.

Input

The input file consists of a number of data sets. Each data set defines one required network. The first line of the set contains two integers: the first defines the number P of the given points, and the second the number R of given routes between the points. The following R lines define the given routes between the points, each giving three integer numbers: the first two numbers identify the points, and the third gives the length of the route. The numbers are separated with white spaces. A data set giving only one number P=0 denotes the end of the input. The data sets are separated with an empty line. 
The maximal number of points is 50. The maximal length of a given route is 100. The number of possible routes is unlimited. The nodes are identified with integers between 1 and P (inclusive). The routes between two points i and j may be given as i j or as j i. 

Output

For each data set, print one number on a separate line that gives the total length of the cable used for the entire designed network.

Sample Input

1 0

2 3
1 2 37
2 1 17
1 2 68

3 7
1 2 19
2 3 11
3 1 7
1 3 5
2 3 89
3 1 91
1 2 32

5 7
1 2 5
2 3 7
2 4 8
4 5 11
3 5 10
1 5 6
4 2 12

0

Sample Output

0
17
16
26

#include<stdio.h>
#include<algorithm>
using namespace std;
int par[150];
struct shit
{
	int x;
	int y;
	int len;
}a[5050];
bool cmp(shit a,shit b)
{
	return a.len<b.len;
}
int find(int x)
{
	return x==par[x]?x:find(par[x]);
}
void unite(int x,int y)
{
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy)
	par[fx]=fy;
}
int main()
{
	int p;
	while( ~scanf("%d",&p),p)
	{
		for(int i=1;i<=p;i++)
		par[i]=i;
		int r;
		scanf("%d",&r);
		int sum=0;
		for(int i=1;i<=r;i++)
		scanf("%d%d%d",&a[i].x ,&a[i].y ,&a[i].len );
		sort(a+1,a+r+1,cmp);
		for(int i=1;i<=r;i++)
		{
			if( find(a[i].x) != find(a[i].y) )
			{
				unite(a[i].x,a[i].y);
				sum+=a[i].len;
			}
		}
		printf("%d\n",sum);
	}
	return 0;
 } 









發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章