HDU 1503 Advanced Fruits (LCS最長公共子序列)

The company "21st Century Fruits" has specialized in creating new sorts of fruits by transferring genes from one fruit into the genome of another one. Most times this method doesn't work, but sometimes, in very rare cases, a new fruit emerges that tastes like a mixture between both of them. 
A big topic of discussion inside the company is "How should the new creations be called?" A mixture between an apple and a pear could be called an apple-pear, of course, but this doesn't sound very interesting. The boss finally decides to use the shortest string that contains both names of the original fruits as sub-strings as the new name. For instance, "applear" contains "apple" and "pear" (APPLEar and apPlEAR), and there is no shorter string that has the same property. 

A combination of a cranberry and a boysenberry would therefore be called a "boysecranberry" or a "craboysenberry", for example. 

Your job is to write a program that computes such a shortest name for a combination of two given fruits. Your algorithm should be efficient, otherwise it is unlikely that it will execute in the alloted time for long fruit names. 
InputEach line of the input contains two strings that represent the names of the fruits that should be combined. All names have a maximum length of 100 and only consist of alphabetic characters. 

Input is terminated by end of file. 
OutputFor each test case, output the shortest name of the resulting fruit on one line. If more than one shortest name is possible, any one is acceptable. 
Sample Input
apple peach
ananas banana
pear peach
Sample Output
appleach
bananas
pearch


分析:

題意:結合兩個字符串,他們的公共子序列只輸出一次。
 
題解:利用LCS算法標記字符,分別標記兩串的公共字符,A串獨有的字符,B串獨有的字符。再利用遞歸函數才大到小遍歷,從小到大回溯輸出,既可以得到題意中要求的雜交串。
 
注意:樣例數據的輸出不一定要和樣例輸出一致,是滿足題目要求的任意雜交串。

#include<stdio.h>
#include<string.h>
char a[1100],b[1100];
int dp[1100][1100],m[1100][1100];
void out(int x,int y)
{
    if(!x&&!y)
        return ;
   else if(m[x][y]==0)//如果相等,輸出哪個都可以
   {
       out(x-1,y-1);
       printf("%c",a[x-1]);
   }
   else if(m[x][y]==1)//如果a字串獨有,輸出a字串字符
   {
       out(x-1,y);
       printf("%c",a[x-1]);
   }
   else if(m[x][y]==-1)//如果b字串長=獨有,輸出b字串字符
   {
       out(x,y-1);
       printf("%c",b[y-1]);
   }
}
int main()
{
    int i,j,a1,b1;
    while(scanf("%s%s",a,b)!=EOF)
    {
        memset(dp,0,sizeof(dp));//初始化數組
        a1=strlen(a);
        b1=strlen(b);
        for(i=0; i<a1; i++)//初始化m數組,從a數組到b數組0下標,都是a長
            m[i][0]=1;
        for(i=0; i<b1; i++)//初始化m數組,從b數組到a數組0下標,都是b長
            m[0][i]=-1;
        for(i=1; i<=a1; i++)
            for(j=1; j<=b1; j++)
                if(a[i-1]==b[j-1]) //如果字符相等,就等於目前相等次數加一
                {
                    dp[i][j]=dp[i-1][j-1]+1;
                    m[i][j]=0;//標記輸出哪一個都可以
                }
                else if(dp[i-1][j]>=dp[i][j-1])
                {
                    dp[i][j]=dp[i-1][j];//更新最長字串
                    m[i][j]=1;//標記字符
                }
                else
                {
                  dp[i][j]=dp[i][j-1];
                  m[i][j]=-1;
                }
       out(a1,b1);
       printf("\n");
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章