poj 2955 Brackets

原題:
Brackets
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 17392 Accepted: 9010

Description

We give the following inductive definition of a “regular brackets” sequence:

the empty sequence is a regular brackets sequence,
if s is a regular brackets sequence, then (s) and [s] are regular brackets sequences, and
if a and b are regular brackets sequences, then ab is a regular brackets sequence.
no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:

(), [], (()), ()[], ()[()]

while the following character sequences are not:

(, ], )(, ([)], ([(]

Given a brackets sequence of characters a1a2 … an, your goal is to find the length of the longest regular brackets sequence that is a subsequence of s. That is, you wish to find the largest m such that for indices i1, i2, …, im where 1 ≤ i1 < i2 < … < im ≤ n, ai1ai2 … aim is a regular brackets sequence.

Given the initial sequence ([([]])], the longest regular brackets subsequence is [([])].

Input

The input test file will contain multiple test cases. Each input test case consists of a single line containing only the characters (, ), [, and ]; each input test will have length between 1 and 100, inclusive. The end-of-file is marked by a line containing the word “end” and should not be processed.

Output

For each input case, the program should print the length of the longest possible regular brackets subsequence on a single line.

Sample Input

((()))
()()()
([]])
)[)(
([][][)
end

Sample Output

6
6
4
0
6

Source
Stanford Local 2004

中文:

給你個括號序列,只由()和[]組成
問你最長的有效括號長度是多少?

代碼:

//#include<bits/stdc++.h>
#include<iostream>
#include<algorithm>
#include<string>
#include<cstring>
using namespace std;
typedef long long ll;

typedef pair<int,int> pii;
const int maxn = 105;
char s[maxn];
int dp[maxn][maxn];

bool cmp(char c1,char c2)
{
    if(c1=='('&&c2==')')
        return true;
    if(c1=='['&&c2==']')
        return true;
    return false;
}

int main()
{
    ios::sync_with_stdio(false);
    while(cin>>&s[1])
    {
        if(s[1]=='e')
        {
            break;
        }
        int len = strlen(&s[1]);
        memset(dp,0,sizeof(dp));

        for(int i=1;i<len;i++)
        {
            if(cmp(s[i],s[i+1]))
                dp[i][i+1]=2;
        }

        for(int l=2;l<=len;l++)
        {
            for(int i=1;i<=len-l;i++)
            {
                int j=i+l;
                if(cmp(s[i],s[j]))
                    dp[i][j]=max(dp[i+1][j-1]+2,dp[i][j]);

                for(int k=i+1;k<j;k++)
                {
                    dp[i][j]=max(dp[i][j],dp[i][k]+dp[k][j]);
                }
            }
        }

        cout<<dp[1][len]<<endl;
    }
    return 0;
}

解答:

簡單的區間dp
輸入括號序列s,狀態轉移方程如下

s[i]==s[j]s[i]==s[j]
dp[i][j]=max(dp[i][j],dp[i+1][j1]+2)dp[i][j]=max(dp[i][j],dp[i+1][j-1]+2)
否則
dp[i][j]=max(dp[i][j],dp[i][k]+dp[k][j])dp[i][j]=max(dp[i][j],dp[i][k]+dp[k][j]) k(i,j)k ∈(i,j)

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章